Bug 1445507 - Plenty of space but getting, "ERROR: Unable to fit DVD image ..."
Summary: Plenty of space but getting, "ERROR: Unable to fit DVD image ..."
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-25 20:11 UTC by Jerry Amundson
Modified: 2017-05-26 04:02 UTC (History)
8 users (show)

Fixed In Version: livecd-tools-24.4-1.fc26 livecd-tools-24.4-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-14 20:17:22 UTC
Type: Bug


Attachments (Terms of Use)
Output script of successful run with livecd-tools-1:24.1-1.fc26 (509.58 KB, text/plain)
2017-04-27 12:57 UTC, Jerry Amundson
no flags Details
Unsuccessful run with livecd-tools-1:24.3-2.fc26 (11.04 KB, text/plain)
2017-04-27 13:07 UTC, Jerry Amundson
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github livecd-tools livecd-tools issues 61 0 None None None 2017-05-05 02:00:19 UTC

Description Jerry Amundson 2017-04-25 20:11:50 UTC
Description of problem:
Plenty of space but getting, "ERROR: Unable to fit DVD image ..."

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. /usr/bin/livecd-iso-to-disk --noverify --format --reset-mbr --efi --label Fedora-LXQt-Live-x86_64-26-20170328.n.0.iso /dev/sdc1
2.
3.

Actual results:
ERROR: Unable to fit DVD image + install.img on the available
        space of the target device.

Expected results:
Successful copy

Additional info:
freespace is not set, as 
[[ -z $skipcopy && live == $srctype ]] && checklivespace
does not run checklisespace on "installer" type.

+ imgpath=images/install.img
+ duTable=($(du -s -B 1M $SRCMNT/$imgpath))
++ du -s -B 1M /run/srctmp.VzOecS/images/install.img
+ installimgsize=329
+ tbd=0
+ [[ -e /run/tgttmp.cyQYSK/images/install.img ]]
+ [[ -e /run/tgttmp.cyQYSK/TrueDef-r184-5.3-34000.iso ]]
+ printf '\nSize of %s:  %s
    \rAvailable space:  %s' images/install.img 329 0

Size of images/install.img:  329
Available space:  0+ ((  installimgsize > ((freespace + tbd))  ))
+ printf '\nERROR: Unable to fit DVD image + install.img on the available
        space of the target device.\n'

ERROR: Unable to fit DVD image + install.img on the available
        space of the target device.
+ exitclean

Comment 1 Jerry Amundson 2017-04-25 21:21:28 UTC
With livecd-tools-24.1-1.fc26.x86_64, the USB is written as expected.

Comment 2 Neal Gompa 2017-04-27 02:09:46 UTC
What version of livecd-tools are you using?

Comment 3 Jerry Amundson 2017-04-27 12:29:25 UTC
livecd-tools-1:24.3-2.fc26.x86_64

Comment 4 Jerry Amundson 2017-04-27 12:57:51 UTC
Created attachment 1274645 [details]
Output script of successful run with livecd-tools-1:24.1-1.fc26

Comment 5 Jerry Amundson 2017-04-27 13:05:07 UTC
livecd-tools-1:24.2-1.fc26 cannot be tested because of Bug 1437601

Comment 6 Jerry Amundson 2017-04-27 13:07:14 UTC
Created attachment 1274647 [details]
Unsuccessful run with livecd-tools-1:24.3-2.fc26

Comment 7 Frederick Grose 2017-05-05 04:55:30 UTC
See https://github.com/livecd-tools/livecd-tools/pull/62

This should restore the expected behavior.

Comment 8 Fedora Update System 2017-05-08 04:59:33 UTC
livecd-tools-24.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d5aa85fd7

Comment 9 Fedora Update System 2017-05-08 05:00:19 UTC
livecd-tools-24.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7076993b7d

Comment 10 Fedora Update System 2017-05-09 00:46:07 UTC
livecd-tools-24.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d5aa85fd7

Comment 11 Fedora Update System 2017-05-09 02:38:20 UTC
livecd-tools-24.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7076993b7d

Comment 12 Jerry Amundson 2017-05-09 12:39:45 UTC
livecd-tools-24.4-1.fc26.x86_64
successfully copied the image.

Comment 13 Fedora Update System 2017-05-14 20:17:22 UTC
livecd-tools-24.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2017-05-26 04:02:18 UTC
livecd-tools-24.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.