Bug 1445523 - [3.5] Subpath does not receive right permissions
Summary: [3.5] Subpath does not receive right permissions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.z
Assignee: Paul Morie
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks: 1445526
TreeView+ depends on / blocked
 
Reported: 2017-04-25 21:20 UTC by Paul Morie
Modified: 2020-09-10 10:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1445526 (view as bug list)
Environment:
Last Closed: 2017-06-15 18:38:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github kubernetes kubernetes issues 41638 0 None None None 2017-04-25 21:25:28 UTC
Github openshift ose pull 725 0 None None None 2017-04-25 21:24:48 UTC
Red Hat Product Errata RHBA-2017:1425 0 normal SHIPPED_LIVE OpenShift Container Platform 3.5, 3.4, 3.3, and 3.2 bug fix update 2017-06-15 22:35:53 UTC

Description Paul Morie 2017-04-25 21:20:19 UTC
Description of problem:

If a subpath is used to mount a volume, the subpath may not receive correct permissions.

See: https://github.com/kubernetes/kubernetes/issues/41638

Version-Release number of selected component (if applicable):

3.5

How reproducible:

Mount a volume via a subpath in the volumemount and try to write to it as a non-root user.

Actual results:

Not writable

Expected results:

Writable

Additional info:


Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 1 Eric Paris 2017-04-25 21:23:28 UTC
3.5 PR
https://github.com/openshift/ose/pull/725

Comment 2 Jianwei Hou 2017-04-27 06:59:42 UTC
Verified subPath is writable 3.5.5.10-1.

Comment 4 Jianwei Hou 2017-06-05 06:41:30 UTC
Verified on v3.5.5.23

Comment 6 errata-xmlrpc 2017-06-15 18:38:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1425


Note You need to log in before you can comment on or make changes to this bug.