Bug 144553 - System does not boot when using initrd after upgrade from fc2
System does not boot when using initrd after upgrade from fc2
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-01-08 00:28 EST by Arne Brutschy
Modified: 2008-02-03 15:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-03 15:25:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Arne Brutschy 2005-01-08 00:28:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.54  [en]

Description of problem:
I upgraded my system from fc2 to fc3 recently. After upgrade, the 
system always hangs when I try to use initrd. This is not so bad, as 
I always compile the required filesystem and storage drivers in the 
kernel. However, I need to use the initrd because of the udev setup, 
to get rid of the "warning: unable to open initial console".

When I include initrd in the grub.conf, the system hangs with the 
following message:

Creating /dev
Starting /udev
Creating root device
Mounting root filesystem
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

This happens when I try to use the old 2.6.8-1.521 and the new 2.6.9-
1.724_FC3 kernel versions as delivered by fedora. The same happens 
when I use self-compiled kernels from these versions (fedora source 
tree) or the vanilla 2.6.10. I tried to use mkinitrd-4.0.6, mkinitrd-
4.1.18-2 and mkinitrd-4.1.20-1, but nothing changed. It does not 
matter if I include "quiet" or "rhgb" as kernel options.

Here is my grub.conf:

title Windows XP
        rootnoverify (hd0,0)
        chainloader +1
title Fedora Core (2.6.10)
        root (hd0,5)
        kernel /vmlinuz-2.6.10 ro rhgb quiet video=radeonfb vga=791
        initrd /initrd-2.6.10.img
title Fedora Core (2.6.9-1.724, Custom Build)
        root (hd0,5)
        kernel /vmlinuz-2.6.9-1.724custom ro rhgb quiet 
video=radeonfb vga=791
        initrd /initrd-2.6.9-1.724custom.img
title Fedora Core (2.6.9-1.724, Fedora Build)
        root (hd0,5)
        kernel /vmlinuz-2.6.9-1.724_FC3 ro rhgb quiet
        initrd /initrd-2.6.9-1.724_FC3.img
title Fedora Core (2.6.8-1.521, Custom Build)
        root (hd0,5)
        kernel /vmlinuz-2.6.8-1.521custom ro rhgb quiet 
video=radeonfb vga=791
        initrd /initrd-2.6.8-1.521custom.img
title Fedora Core (2.6.8-1.521, Fedora Build)
        root (hd0,5)
        kernel /vmlinuz-2.6.8-1.521 ro rhgb quiet
        initrd /initrd-2.6.8-1.521.img

The system _only_ boots when I delete the initrd line from grub. Here 
is my disk layout:

Disk /dev/hda: 40.0 GB, 40007761920 bytes
240 heads, 63 sectors/track, 5168 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        3017    22808488+   7  HPFS/NTFS
/dev/hda2            3018        5093    15694560    5  Extended
/dev/hda3            5094        5168      567000   a0  IBM Thinkpad 
/dev/hda5            3018        3852     6312568+  83  Linux
/dev/hda6            3853        3866      105808+  83  Linux
/dev/hda7            3867        4954     8225248+  83  Linux
/dev/hda8            4955        5093     1050808+  82  Linux swap

My fstab:

# This file is edited by fstab-sync - see 'man fstab-sync' for 
/dev/hda7               /                       ext3    defaults      
  1 1
/dev/hda6               /boot                   ext3    defaults      
  1 2
/dev/hda5               /home/arne              ext3    defaults      
  1 2

none                    /dev/pts                devpts  gid=5,
mode=620  0 0
none                    /dev/shm                tmpfs   defaults      
  0 0
none                    /proc                   proc    defaults      
  0 0
none                    /sys                    sysfs   defaults      
  0 0

/dev/hda8               swap                    swap    defaults      
  0 0

/dev/hda1               /windows/c              ntfs    ro,
umask=0222,nls=utf8  0 0
/dev/sda5               /windows/d              ntfs    noauto,ro,
umask=0222,nls=utf8   0 0
#/dev/sdb5              /windows/d              ntfs    noauto,ro,
umask=0222,nls=utf8   0 0
/dev/hdc                /media/cdrecorder       auto    pamconsole,
exec,noauto,managed 0 0

System is a Thinkpad T40 (P4, i845 Chipset, Ati Radeon).

I tried the following mkinitrd commands:

mkinitrd -v -f /boot/initrd-2.6.10.img 2.6.10
mkinitrd -v -f --builtin=ide-disk --builtin=ext3 /boot/initrd-2.6.10.
img 2.6.10

Same result every time.

Version-Release number of selected component (if applicable):
mkinitrd-4.0.6 mkinitrd-4.1.18-2 mkinitrd-4.1.20-1

How reproducible:

Steps to Reproduce:
1. compile kernel (with or without needed modules) or take a 
precompiled one
2. create an initrd for that kernel (or use the created one)
3. include thin initrd in boot entry
4. reboot   

Actual Results:  system hangs

Expected Results:  system boots :)

Additional info:
Appeared after upgrade FC2->FC3 using yum
Comment 1 Arne Brutschy 2005-01-13 03:36:17 EST
Problem vanishes after including root=/dev/hda7 as kernel paramters. 
Applies to all tested kernel versions as well as the new 2.6.10-1.737
Before the upgrade, it did work without the root=something at all. So 
perhaps this bug is in the wrong section.
Comment 2 Matthew Miller 2005-01-14 16:48:49 EST
It's possible that this is related to bug #144441. That shouldn't
affect FC3, but may still catch you when you're doing a live update
from FC2 -> FC3.
Comment 3 Matthew Miller 2006-07-10 17:07:09 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 4 petrosyan 2008-02-03 15:25:56 EST
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA", however if you still
experience this problem after updating to our latest Fedora
release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.