Bug 1445696 - [RFE]Ensure correct repositories enabled on overcloud nodes before stack update
Summary: [RFE]Ensure correct repositories enabled on overcloud nodes before stack update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Ana Krivokapic
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-26 10:20 UTC by Chaitanya
Modified: 2018-06-27 13:31 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-validations-8.4.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:29:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 515412 None MERGED Enhance repo validation to check for unwanted enabled repos 2020-09-17 16:15:43 UTC
Red Hat Bugzilla 1575946 None NEW [RFE] Validate if necessary repositories are enabled on the overcloud nodes before starting a minor update or a major up... 2019-02-08 06:20:13 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:31:00 UTC

Description Chaitanya 2017-04-26 10:20:52 UTC
Description of problem:
While performing the minor update of OSP, it would be good if we can check which repositories are enabled on the overcloud nodes. 

If there are some extra repositories enabled like EPEL, there should be a error displayed and the update process should abort.

On one of our setup, we faced this issue. We had EPEL repository enabled on controller nodes, which updated the packages on a controller node and galara went down because of package mismatch on the controllers.


How reproducible:
Always



Actual results:
No warning / error displayed if any extra repository enabled on overcloud nodes.

Expected results:
Operation should abort immediately with an error.

Comment 6 Udi 2018-04-24 08:38:47 UTC
Verified in: openstack-tripleo-validations-8.4.0-2.el7ost.noarch

This only checks if EPEL is enabled (and fails if it is), and checks that there is at least 1 repo enabled. It doesn't guarantee that the *correct* repos are enabled for the upgrade.

Chaitanya, if you would like to additionally verify that the needed repos are not missing, please specify what those repos are. You can re-open this bug or file a new one.

Comment 7 Chaitanya 2018-05-08 06:49:04 UTC
I think there should be a verification of those repositories which should commonly be enabled on all the overcloud nodes (be it controllers, computes or ceph nodes).

There are some scenarios where we have ceph nodes in the overcloud stack for which we will have to enable the mon and osd repos on controllers and ceph nodes, otherwise these repos are not required.

Would this be doable here? If not, I think we can only verify the common repos as stated earlier. Let me know and I will raise a separate bug for it.

Comment 8 Ana Krivokapic 2018-05-08 09:30:41 UTC
It's definitely doable - we can have a list of 'mandatory' and a list of 'forbidden' repos. Please open another bug with as much detail as possible as to what these repos should be.

Comment 9 Chaitanya 2018-05-08 11:13:37 UTC
I have opened another bug to validate the necessary repositories required ahead of beginning a minor update / major upgrade: https://bugzilla.redhat.com/show_bug.cgi?id=1575946

Comment 11 errata-xmlrpc 2018-06-27 13:29:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.