Bug 1445716 - "Check connectivity to various OpenStack services" validation fails
Summary: "Check connectivity to various OpenStack services" validation fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z4
: 11.0 (Ocata)
Assignee: Florian Fuchs
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-26 11:16 UTC by Ola Pavlenko
Modified: 2018-02-13 16:38 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-validations-5.5.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-13 16:38:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 474189 None None None 2017-09-04 13:47:41 UTC
Red Hat Product Errata RHBA-2018:0311 normal SHIPPED_LIVE Red Hat OpenStack Platform 11 Bug Fix and Enhancement Advisory 2018-02-14 00:05:57 UTC

Description Ola Pavlenko 2017-04-26 11:16:11 UTC
Description of problem:

"Check connectivity to various OpenStack services"  validation fails
Version-Release number of selected component (if applicable):
openstack-tripleo-ui-3.1.0-9.el7ost.noarch

How reproducible:
always

Steps to Reproduce:
1.deploy overcloud via UI
2.run the validation 

Actual results:
The validation fails with following output:
Task 'fail' failed:
Host: localhost
Message: The `KeystoneURL` output is not available in the deployed stack.

Failure! The validation failed for all hosts:
* localhost

Expected results:
Validation should pass
$ . stackrc 
$ openstack stack output show overcloud KeystoneURL
+--------------+----------------------------------------+
| Field        | Value                                  |
+--------------+----------------------------------------+
| description  | URL for the Overcloud Keystone service |
| output_key   | KeystoneURL                            |
| output_value | http://192.168.24.9:5000/v2.0          |
+--------------+----------------------------------------+


Additional info:
overcloudrc file was manually created after the deployment vi UI
$ cat overcloudrc 
# Clear any old environment that may conflict.
for key in $( set | awk '{FS="="}  /^OS_/ {print $1}' ); do unset $key ; done
NOVA_VERSION=1.1
export NOVA_VERSION
OS_PASSWORD=zY9Ks7VhyEzRsa8UaTCkXsCCA
export OS_PASSWORD
OS_AUTH_TYPE=password
export OS_AUTH_TYPE
OS_AUTH_URL=http://192.168.24.9:5000
PYTHONWARNINGS="ignore:Certificate has no, ignore:A true SSLContext object is not available"
export OS_AUTH_URL
export PYTHONWARNINGS
OS_USERNAME=admin
COMPUTE_API_VERSION=1.1
OS_NO_CACHE=True
OS_CLOUDNAME=overcloud
export OS_USERNAME
export COMPUTE_API_VERSION
export OS_NO_CACHE
export OS_CLOUDNAME

Comment 1 Lon Hohberger 2017-10-10 18:09:25 UTC
According to our records, this should be resolved by openstack-tripleo-validations-5.5.0-2.el7ost.  This build is available now.

Comment 5 errata-xmlrpc 2018-02-13 16:38:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0311


Note You need to log in before you can comment on or make changes to this bug.