Bug 144577 - NetworkManager won't cooperate with adm8211 WLAN driver
NetworkManager won't cooperate with adm8211 WLAN driver
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-08 13:46 EST by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-16 15:43:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2005-01-08 13:46:09 EST
Description of problem:
I have a laptop, which has a built in wired interface, and a cardbus
SMC WLAN interface driven by the adm8211 driver. The card is correctly
recognized by kudzu after compiling the module, and works (i am typing
this from the laptop, over the WLAN link)

However, if networkmanager is started, the whole PC seems to "freeze"
a secound every secound when the card is inserted (and started by
hotplug, i would guess - if NM isn't running, it will just connect to
the first and best network aviable...), but if it's running, it wont
connect at all, just scan. (at least kWiFi shows channel numbers
scanning wildly)

If i try to start NetworkManagerInfo (from a terminal), it will just
wait a secound and then return.

Version-Release number of selected component (if applicable):
0.3.1-3

How reproducible:
Every time

Steps to Reproduce:
1.Start network-manager service
2.Plug in the card
3.watch top and try to use the pc
  
Actual results:
Boom...

Expected results:
Having the nice, little config thing etc...

Additional info:
I am sometimes having some troubles with ifdown eth0 (ethernet card),
going to report that as a kernel bug now. Ill get back to post the link.
Comment 1 Kyrre Ness Sjøbæk 2005-01-08 14:12:14 EST
Bug with ethernet-card #144579
Comment 2 Kyrre Ness Sjøbæk 2005-01-15 13:42:22 EST
Hmm... after upgrading HAL, NetworkManager, and kernel (to the last
2.6.9 that was pushed - it was so close to 2.6.10 that i was able to
compile the "2.6.10 only driver" for it - newest version), it now
works better - ie it doesn't make my pc lag as hell, and
NetworkManagerInfo comes up and detects the card and the network.

But it still isn't able to connect. I chose "wireless network ->
kyrre" (name of my local network). It searches for a long time, and
then tries to connect. I have seen it connect sucsessfully once - i.e.
it did get an IP etc., but i wasn't able to ping anything... Routing
table also looked kindof "wierd". (no eth0 stuff, just 3 or 4 entries
for eth1). And it was dead slow. In comparison, netplugd uses about 5
secounds from plugging in network cardbus card (including detecting
card and loading driver, getting IP and setting everything up).

But it looks great ! :D If only it would work...
Comment 3 Dan Williams 2005-01-29 17:52:22 EST
Can you give the URL of the driver you're using?  I'm fairly sure
that's not an upstream kernel driver.  I'll take a look at the driver
code to see if its more or less sane.

Thanks,
Dan
Comment 4 Kyrre Ness Sjøbæk 2005-01-30 07:06:34 EST
http://aluminum.sourmilk.net/adm8211/

No its not an upstream kernel driver (yet). But it works, and enables
me to use the wlan card really nicely.

As of my last test, NetworkManager worked with the card, but it was
very slow. It was "connecting" for 2 minutes...

But network selection worked, and it did eventually come up. But its
really strange that it is so slow when hotplug/netplugd uses about
five secounds to bring the network up after i have inserted the card...
Comment 5 Kyrre Ness Sjøbæk 2005-08-10 12:21:51 EDT
The bug is gone - it "just works" now. You may close this bug.

Btw. great work on NetworkManager!
Comment 6 Kyrre Ness Sjøbæk 2006-02-16 15:43:45 EST
i'm taking the freedom to close this bug myself. it is fixed, as commentet
above. I'm not completely shure which to pick, but "Worksforme" seems fine :)

Note You need to log in before you can comment on or make changes to this bug.