Bug 144578 - hal - segfault from /usr/sbin/fstab-sync on a music CD eject
hal - segfault from /usr/sbin/fstab-sync on a music CD eject
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-08 13:50 EST by Michal Jaegermann
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.4.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 15:56:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-01-08 13:50:11 EST
Description of problem:

I am collecting pretty consistently in /var/log/messages entries
like that:

kernel: 50-fstab-sync.h[20448]: segfault at 0000000000000000
      rip 000000307706f6b2 rsp 0000007fbffff6d8 error 4

A way to generate the next one is as follows:
  - put a CD with music into a drive
  - play it
  - hit "eject" button on a CD player interface
  - after a short while a new "segfault" shows up in logs

AFAICT this does not happens on i386 installation.


Version-Release number of selected component (if applicable):
hal-0.4.2-1.FC3

How reproducible:
See above.
Comment 1 David Zeuthen 2005-01-13 14:13:27 EST
Hi,

Interestingly enough I just got a AMD64 system at home and I could
indeed reproduce this - I've also fixed the bug. Please see if
hal-0.4.5 works; it's both in Rawhide and FC3 updates.

Thanks,
David
Comment 2 Michal Jaegermann 2005-01-13 17:19:07 EST
> Please see if hal-0.4.5 works

Hm, just installed hal-0.4.5-1.FC3, restarted it myself just to be
sure, and immediately got with a timestamp "Jan 13 15:09:42":

kernel: 50-fstab-sync.h[14431]: segfault at 0000000000000000
    rip 000000307706f6b2 rsp 0000007fbffff6d8 error 4

after ejecting a CD from my CD player.  Exactly the same error as
before.  Looks like something dereferencing a NULL pointer.
Comment 3 David Zeuthen 2005-01-21 11:02:51 EST
I think I fixed this; I haven't got a AMD64 handy right now but there
is a SRPM here

 http://people.redhat.com/davidz/hal-cvs20050121/

you can rebuild the x86_64 packages from. Let me know if I should run
it through the build system. 

Thanks,
David
Comment 4 Michal Jaegermann 2005-01-21 15:07:42 EST
Recompiling that I run immediately into a trouble described in
bug #138742.  How your build system works around that and when
this will be fixed?  But that is a digression...

Indeed hal-0.4.6.cvs20050121-1 seems to be behave.  There is
one caveat.  With hal-0.4.6-1.FC3, which showed up in updates
very recently, I had to try some five times before I got
a familiar
  50-fstab-sync.h[18286]: segfault at 0000000000000000
        rip 000000307706f6b2 rsp 0000007fbffff6d8 error 4
while previously this looked like really every time.  Makes sense?
I did not manage to reproduce that so far with
hal-0.4.6.cvs20050121-1 but maybe I have to do fifty attempts?
There is no track of patches in src.rpm where I can peek.

OTOH when not segfaulting hal-0.4.6-1.FC3 was complaining

Device not ready.  Make sure there is a disc in the drive.

and I do not see that with hal-0.4.6.cvs20050121-1.  So even
if this is a race which may still show up in some circumstances
it looks to me that the last version is a significant improvement
in any case.
Comment 5 Michal Jaegermann 2005-01-25 15:54:49 EST
A quick check with hal-0.4.7-1.FC3 does not show any segfaults
after a CD was ejected few times.  No spurious "Device not ready"
messages either.
Comment 6 David Zeuthen 2005-01-25 15:56:59 EST
> A quick check with hal-0.4.7-1.FC3 does not show any segfaults
> after a CD was ejected few times.  

Excellent, thanks for the testing.

> No spurious "Device not ready" messages either.

This is probably because the kernel got fixed.

Note You need to log in before you can comment on or make changes to this bug.