Bug 1445817 - Error: Failed to synchronize cache for repo 'fedora-cisco-openh264'
Summary: Error: Failed to synchronize cache for repo 'fedora-cisco-openh264'
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-26 14:56 UTC by Chris Murphy
Modified: 2018-05-01 16:03 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-05-03 11:37:12 UTC


Attachments (Terms of Use)

Description Chris Murphy 2017-04-26 14:56:29 UTC
Description of problem:

dnf always fails with
Error: Failed to synchronize cache for repo 'fedora-cisco-openh264'


Version-Release number of selected component (if applicable):
dnf-2.3.0-1.fc26.noarch

How reproducible:
Always

Steps to Reproduce:
1. dnf update
2.
3.

Actual results:

Error


Expected results:

Should work, or fail gracefully or provide more information on what the problem is by default.


Additional info:

$ sudo dnf update -v
Loaded plugins: builddep, config-manager, copr, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, reposync
DNF version: 2.3.0
cachedir: /var/cache/dnf
Cannot download 'https://codecs.fedoraproject.org/openh264/26/x86_64/': repomd.xml GPG signature verification error: Bad GPG signature.
Error: Failed to synchronize cache for repo 'fedora-cisco-openh264'

The repo was added per this page:
https://fedoraproject.org/wiki/OpenH264

It doesn't mention anything about GPG.

Disabling fedora-cisco-openh264 solves the problem.

Comment 1 Daniel Mach 2017-05-03 11:37:12 UTC
This seems to be caused by not having GPG key from F26 installed. You need to install a correct key prior doing that. To my understanding, it's correct behavior unless you want to use  --nogpgcheck option or disable the repo as you suggested.

Comment 2 Daniel 2017-05-26 14:29:46 UTC
Please reopen.

I do have the repository keys for Fedora 26 installed. It’s only the fedora-cisco-openh264 repository that fails. The specific key referenced in the .repo file is installed on the system.

Comment 3 Tobias Schönberg 2017-07-22 10:14:37 UTC
Using "sudo dnf update --nogpgcheck" does not help either with this issue. Whatever is happening with DNF, the error message needs to be more than just "Error" and "Failed".

Comment 4 robert 2018-04-27 05:36:10 UTC
This happens in Fedora 27 as well. This started happening after I installed all the codec options available in Gnome's Software GUI interface. Totem actually came up with the popup suggesting the missing codecs and that's where I got them from.

Comment 5 robert 2018-04-27 05:40:06 UTC
If anyone else comes across this bug on Google like I did, this is what I did to fix it. Go to your terminal and login as root or use sudo.
$ sudo rm /etc/yum.repos.d/fedora-cisco-openh264.repo

Now dnf update should work

Comment 6 Abed 2018-05-01 16:03:14 UTC
i got this error while i was trying to install something, after some i found this page
https://forums.fedoraforum.org/showthread.php?315298-dnf-Error-Failed-to-synchronize-cache-for-repo-updates

i ran

$ sudo dnf --disablerepo=\* --enablerepo=updates update --refresh

massive amount of updates/upgrades happened

then:

$ sudo dnf update

it imported GPG key, then another, though smaller, amount of updates happened.

hope this helps someone with the same problem.


Note You need to log in before you can comment on or make changes to this bug.