Bug 144588 - Xchat intercepts arrow-down - regression
Xchat intercepts arrow-down - regression
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-08 18:55 EST by Pete Zaitcev
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 17:50:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (639 bytes, patch)
2005-02-18 01:50 EST, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Pete Zaitcev 2005-01-08 18:55:28 EST
Description of problem:

When trying to katakanize a set of hiragana, I hit arrow down key.
Before, it was interpreted by the input method. But now it goes
into the x-chat.

This may be an x-chat problem specifically, because arrow-down
continues to work in gnome-terminal ok (e.g. does NOT get into
the gnome-terminal itself).

A workaround is avaible, by hitting Control-N.

Version-Release number of selected component (if applicable):

iiimf-gtk-12.1-4
iiimf-gnome-im-switcher-12.1-4
iiimf-server-12.1-4
iiimf-libs-devel-12.1-4
iiimf-csconv-12.1-4
iiimf-le-unit-12.1-4
iiimf-libs-12.1-4
iiimf-le-canna-12.1-4
iiimf-x-12.1-4
xchat-2.4.0-3

How reproducible:

100%

Steps to Reproduce:
1. Start xchat. You will not send anything, so just get an input box.
2. Type some garbage. You will recall it from history.
3. Switch to Ja with GIMLET for x-chat. A little IIIMF window will
   appear near the corner of x-chat.
4. Type a few kana, hit cursor down. NOTHING HAPPENS.
5. Hit cursor up: the x-chat will recall the garbage you typed at
   step 2.

Actual results:

Arrow keys get delivered to x-chat

Expected results:

Arrow keys to rotate between hiragana, katakana, romanji.

Additional info:

I do not remember precisely what the last working version was
and it it has broke with new xchat or new iiimf. I ran "yum update"
and this started to happen, about three weeks ago.
Comment 1 Pete Zaitcev 2005-01-08 18:56:58 EST
Setting severity to low, because a workaround is available.
Comment 4 Akira TAGOH 2005-02-18 01:49:23 EST
Well, surely this is a xchat bug, because it doesn't call
gtk_im_context_filter_keypress() before doing something with the key events. so
there is no way to filter the key which the Input Method wants to use. reassigning.
Comment 5 Akira TAGOH 2005-02-18 01:50:35 EST
Created attachment 111193 [details]
proposed patch

Note You need to log in before you can comment on or make changes to this bug.