Bug 1445890 - Creating a project horizon gui display error unable to set project quotas
Summary: Creating a project horizon gui display error unable to set project quotas
Keywords:
Status: CLOSED DUPLICATE of bug 1414997
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-26 17:37 UTC by bigswitch
Modified: 2019-09-09 13:39 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-28 12:46:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description bigswitch 2017-04-26 17:37:36 UTC
Description of problem:
When creating a new project, horizon gui will display an error: unable to set project quotas popup

Version-Release number of selected component (if applicable):
RHOSP10

How reproducible:
100%

Steps to Reproduce:
1. Login to Horizon
2. Create a new project


Additional info:
This is seen in horizon log

==> /var/log/horizon/horizon.log <==
2017-04-26 17:33:18,435 613881 WARNING horizon.exceptions Recoverable error: gigabytes must be an integer. (HTTP 400) (Request-ID: req-19e3e7b9-9f4f-4843-9820-d9386a0d30bc)

Comment 1 Artom Lifshitz 2017-04-28 12:37:28 UTC
I'm going to recategorise this bug to Horizon, since it doesn't appear that Nova is involved at any point.

Pure speculation from my part, as a Nova and not Horizon engineer - but it looks like a non-integer value was entered into a field that only accepts integers, and perhaps Horizon isn't handling that error condition very well.

Comment 2 Radomir Dopieralski 2017-04-28 12:46:26 UTC

*** This bug has been marked as a duplicate of bug 1414997 ***


Note You need to log in before you can comment on or make changes to this bug.