Bug 144611 - unable to build iscsi module after kernel upgrade (sock_getsockopt unknown symbol)
unable to build iscsi module after kernel upgrade (sock_getsockopt unknown sy...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 14:02 EST by Antonin Mares
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-09 15:23:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Mares 2005-01-09 14:02:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040913

Description of problem:
After upgrade to kernel 2.6.9-1.724_FC3 from previous kernel package
I'm no longer able to build iSCSI driver from
http://linux-iscsi.sourceforge.net

During make I get the following warning:
** Warning: "sock_getsockopt"
[/root/linux-iscsi-4.0.1.10/driver/iscsi_sfnet.ko]

and attempt to insert the module fails with:
iscsi_sfnet: Unknown symbol sock_getsockopt

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.724_FC3

How reproducible:
Always

Steps to Reproduce:
1. Get sources from project homepage
(http://linux-iscsi.sourceforge.net). For exmaple use mirror
http://mesh.dl.sourceforge.net/sourceforge/linux-iscsi/linux-iscsi-4.0.1.10.tgz

2. Untar it.

3. Run "make"

Actual Results:  [r...@localhost ~]# cd linux-iscsi-4.0.1.10
[r...@localhost linux-iscsi-4.0.1.10]# make

Note: using kernel source from /lib/modules/2.6.9-1.724_FC3/build
containing kernel version 2.6.9-1.724_FC3

Note: using kernel config from /lib/modules/2.6.9-1.724_FC3/build/.config

make[1]: Entering directory `/lib/modules/2.6.9-1.724_FC3/build'
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-initiator.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-attr.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-session.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-timer.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-task.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-portal.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-ioctl.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-network.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-recv-pdu.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-xmit-pdu.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-recovery.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-crc.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi-auth.o
  CC [M]  /root/linux-iscsi-4.0.1.10/driver/../common/login/iscsi-login.o
CC [M]
/root/linux-iscsi-4.0.1.10/driver/../common/auth/iscsi-auth-client.o
  LD [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi_sfnet.o
Building modules, stage 2.
MODPOST
Warning: could not find versions for .tmp_versions/iscsi_sfnet.mod
*** Warning: "sock_getsockopt"
[/root/linux-iscsi-4.0.1.10/driver/iscsi_sfnet.ko] undefined!
 CC      /root/linux-iscsi-4.0.1.10/driver/iscsi_sfnet.mod.o
  LD [M]  /root/linux-iscsi-4.0.1.10/driver/iscsi_sfnet.ko

....
Comment 1 Dave Jones 2005-01-09 15:23:24 EST
this got removed upstream. the iscsi folks will need to bring it up on
linux-kernel if they want this reinstated.

Note You need to log in before you can comment on or make changes to this bug.