Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1446154

Summary: ns-slapd - LOGINFO:Unable to remove file (frontport to rhel7)
Product: Red Hat Enterprise Linux 7 Reporter: German Parente <gparente>
Component: 389-ds-baseAssignee: mreynolds
Status: CLOSED ERRATA QA Contact: Viktor Ashirov <vashirov>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.4CC: amsharma, nkinder, rmeggins
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 389-ds-base-1.3.6.1-7.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-01 21:16:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description German Parente 2017-04-27 10:45:57 UTC
Description of problem:

this is just request to deliver in RHEL7 this fix:


https://bugzilla.redhat.com/show_bug.cgi?id=1260622
ns-slapd - LOGINFO:Unable to remove file 

https://pagure.io/389-ds-base/issue/48304
ns-slapd - LOGINFO:Unable to remove file

In fact, the fix is very simple not to give but a warning if the file is not there.

The commit has been done in all the branches but it has not delivered into RHEL7.

I am asking because a customer has hit it in RHEL7 and he/she will want probably the fix.

regards,

German.

Comment 2 mreynolds 2017-05-03 18:56:19 UTC
Was fixed in the rebase for rhel-7.4

Comment 4 Amita Sharma 2017-05-31 08:29:21 UTC
[root@qeos-7 slapd-qeos-7]# rpm -qa | grep 389
389-ds-base-libs-1.3.6.1-15.el7.x86_64
389-ds-base-1.3.6.1-15.el7.x86_64
389-ds-base-snmp-1.3.6.1-15.el7.x86_64
389-ds-base-debuginfo-1.3.6.1-15.el7.x86_64


1. Setup log rotation like below

ldapmodify -x -h localhost -p 389 -D "cn=directory manager" -w Secret123 -a << EOF
dn: cn=config
changetype: modify
replace: nsslapd-errorlog-maxlogsize
nsslapd-errorlog-maxlogsize: 1
-
replace: nsslapd-errorlog-maxlogsperdir
nsslapd-errorlog-maxlogsperdir: 5
-
replace: nsslapd-errorlog-level
nsslapd-errorlog-level: 1

2. Delete any of the rotation file and Check the error in the original bug report -

[root@qeos-7 slapd-qeos-7]# ls -al
total 6604
drwxrwx---. 2 dirsrv dirsrv     247 May 31 04:27 .
drwxr-xr-x. 3 root   root        26 May 31 03:53 ..
-rw-------. 1 dirsrv dirsrv 2125134 May 31 04:27 access
-rw-------. 1 dirsrv dirsrv      63 May 31 03:53 access.rotationinfo
-rw-------. 1 dirsrv dirsrv       0 May 31 03:53 audit
-rw-------. 1 dirsrv dirsrv      63 May 31 03:53 audit.rotationinfo
-rw-------. 1 dirsrv dirsrv   49086 May 31 04:27 errors
-rw-------. 1 dirsrv dirsrv 1048639 May 31 04:27 errors.20170531-042658
-rw-------. 1 dirsrv dirsrv 1048648 May 31 04:27 errors.20170531-042702
-rw-------. 1 dirsrv dirsrv 1048590 May 31 04:27 errors.20170531-042706
-rw-------. 1 dirsrv dirsrv 1048652 May 31 04:27 errors.20170531-042710
-rw-------. 1 dirsrv dirsrv     471 May 31 04:27 errors.rotationinfo

[root@qeos-7 slapd-qeos-7]# rm errors.20170531-042710
rm: remove regular file ‘errors.20170531-042710’? y

[root@qeos-7 slapd-qeos-7]# grep -i "Unable to remove file" *

Comment 5 errata-xmlrpc 2017-08-01 21:16:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2086