Bug 1446215 - NoOpFirewallDriver is set in Nova validation on setup with composable roles
Summary: NoOpFirewallDriver is set in Nova validation on setup with composable roles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Florian Fuchs
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-27 13:15 UTC by Ola Pavlenko
Modified: 2018-06-27 13:31 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-validations-8.2.1-0.20180220034948.6dc1ba3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:29:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 500067 None master: MERGED tripleo-validations: Add separate fail-if-no-hosts plugin (Icb364e3dd04f5094782d4a1773bc548f2428afec) 2018-02-28 13:29:08 UTC
OpenStack gerrit 521534 None master: MERGED tripleo-validations: Change Nova firewall driver validation host (I6607478c7045ef69f4764ebb1d65ff322bb26237) 2018-02-28 13:29:01 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:31:00 UTC

Description Ola Pavlenko 2017-04-27 13:15:39 UTC
Description of problem:
Running "NoOpFirewallDriver is set in Nova" shows success with Warning! The validation did not run on any host
Accessing compute nodes manually and checking nova.conf proves that validation should pass
The validation correctly passes on setup without composable roles

Version-Release number of selected component (if applicable):
openstack-tripleo-ui-3.1.0-9.el7ost.noarch

How reproducible:
always

Steps to Reproduce:
1. deploy overcloud with composable roles with more than 1 compute
2. run the validation 

Actual results:
shows success although didn't run on any of the hosts

Expected results:
should run, and pass

Additional info:
or fail because it didn't run

Comment 3 Florian Fuchs 2017-11-20 13:47:01 UTC
There are 2 patches which address this issue:

1. https://review.openstack.org/#/c/521534/

This changes the validation's host group to nova_compute, which means it will run on any roles that have that service installed, even if they're composable roles that are not named "Compute".

2. https://review.openstack.org/#/c/500067/

This adds a callback plugin that lets all validations fail if there are no hosts to run on.

Comment 5 Udi 2018-05-22 09:01:21 UTC
Verified:
openstack-tripleo-validations-8.4.1-5.el7ost.noarch

Comment 7 errata-xmlrpc 2018-06-27 13:29:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.