Bug 144624 - Map "Mod4+Backspace" to "Insert" using xkb
Map "Mod4+Backspace" to "Insert" using xkb
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
https://bugs.freedesktop.org/show_bug...
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 17:50 EST by Gabriel Schulhof
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 20:41:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A better patch (I forgot to enable repeat for the modified Backspace key) (1.22 KB, patch)
2005-01-09 21:09 EST, Gabriel Schulhof
no flags Details | Diff

  None (edit)
Description Gabriel Schulhof 2005-01-09 17:50:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.5)
Gecko/20041220 Fedora/1.7.5-2

Description of problem:
Apple iBook laptop keyboards do not have an "Insert" key.  These
modifications
to some of the xkb configuration files will cause the Mod4+Backspace
combination
to produce a clean "Insert".  This can then be used in text editors
and word
processors for toggling insert/overtype mode.

This modification should go completely unnoticed by people who do have an
"Insert" key. I tested it on a computer with an "Insert" key (a
regular IBM PC
compatible) and it didn't affect it at all. "Mod4+Insert" results in
just that,
and "Mod4+Backspace" results in "Insert".

I suppose the only side effect is that the user cannot assign
"Mod4+Backspace"
to anything in, say, the "Keyboard Shortcuts" applet, because trying
to do so
would cause "Insert" to be bound to something, and not "Mod4+Backspace".

diff -r -u xkb.orig/symbols/pc/pc xkb/symbols/pc/pc
--- xkb.orig/symbols/pc/pc      2004-12-18 07:19:58.000000000 -0700
+++ xkb/symbols/pc/pc   2005-01-09 14:26:36.000000000 -0700
@@ -24,7 +24,8 @@

     key <BKSP> {
         type="CTRL+ALT",
-        symbols[Group1]= [ BackSpace,   Terminate_Server ]
+        symbols[Group1]= [ BackSpace,   Terminate_Server, Insert ],
+        actions[Group1]= [
Noaction(),NoAction(),Redirect(key=<INS>,clearmods=Mod4)]
     };

     key  <TAB> {       [       Tab,    ISO_Left_Tab    ]       };
diff -r -u xkb.orig/types/pc xkb/types/pc
--- xkb.orig/types/pc   2004-12-18 07:19:58.000000000 -0700
+++ xkb/types/pc        2005-01-09 14:23:21.000000000 -0700
@@ -6,7 +6,7 @@
     // Some types that are necessary
     // for a full implementation of
     // a PC compatible keyboard.
-    virtual_modifiers Alt;
+    virtual_modifiers Alt,Mod4;

     type "PC_BREAK" {
        modifiers = Control;
@@ -25,9 +25,11 @@
     };

     type "CTRL+ALT" {
-       modifiers = Control+Alt;
+       modifiers = Control+Alt+Mod4;
        map[Control+Alt] = Level2;
+        map[Mod4] = Level3;
        level_name[Level1] = "Base";
        level_name[Level2] = "Ctrl+Alt";
+       level_name[Level3] = "Mod4";
     };
 };


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1.901-1

How reproducible:
Always

Steps to Reproduce:
1. Buy an Apple iBook
2. Open the lid.
3. Look for the "Insert" key.

Actual Results:  You will find no "Insert" key.

Expected Results:  What kind of a self-respecting laptop doesn't have
an "Insert" key ... *shake head* ...

Additional info:

None.
Comment 1 Gabriel Schulhof 2005-01-09 21:09:30 EST
Created attachment 109544 [details]
A better patch (I forgot to enable repeat for the modified Backspace key)
Comment 2 Mike A. Harris 2005-02-01 00:03:37 EST
Please report this issue to X.org via X.Org bugzilla, located
at: http://bugs.freedesktop.org in the "xorg component.  Once
you have filed your X.Org bug report, please paste the URL here,
and Red Hat will track the issue in the X.Org bugzilla, and
consider including any officially accepted solutions into future
Fedora Core erratum.
Comment 3 Mike A. Harris 2005-02-01 00:04:17 EST
Setting status to "NEEDINFO", awaiting upstream bug report URL.
Comment 4 Gabriel Schulhof 2005-02-01 20:08:09 EST
I have created the bug at bugs.freedesktop.org:

https://bugs.freedesktop.org/show_bug.cgi?id=2448

Please have a look at it :o)

I have changed the bug's status away from NEEDINFO to the only other
one that was not a resolution and was available to me. Ig it's
incorrect, please change it accordingly.
Comment 5 Mike A. Harris 2005-02-07 20:41:11 EST
Thanks for the Xorg bug URL.  Setting status to "UPSTREAM" for
tracking in the X.Org bugzilla.

Note You need to log in before you can comment on or make changes to this bug.