Bug 1446260 - HAProxy configuration validation fails
Summary: HAProxy configuration validation fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Gaël Chamoulaud
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-27 14:19 UTC by Ola Pavlenko
Modified: 2018-06-27 13:31 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-validations-8.2.1-0.20180220034948.6dc1ba3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:29:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1687626 None None None 2017-10-04 13:25:32 UTC
OpenStack gerrit 460610 None master: MERGED tripleo-validations: Add 'become: true' to haproxy validation (Iad642d1d30811655f6d2f0261b3309250c4f0aea) 2018-02-28 13:29:26 UTC
OpenStack gerrit 461795 None stable/ocata: MERGED tripleo-validations: Add 'become: true' to haproxy validation (Iad642d1d30811655f6d2f0261b3309250c4f0aea) 2018-02-28 13:29:19 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:31:00 UTC

Description Ola Pavlenko 2017-04-27 14:19:51 UTC
Description of problem:
HAProxy configuration validation fails on regular deployment (3 controller + 1 compute + 1 ceph no composable roles) with :
Task 'Gather the HAProxy config' failed:
Host: 192.168.24.10
Message: Could not open the haproxy conf file at: '/etc/haproxy/haproxy.cfg'

Task 'Gather the HAProxy config' failed:
Host: 192.168.24.7
Message: Could not open the haproxy conf file at: '/etc/haproxy/haproxy.cfg'

Task 'Gather the HAProxy config' failed:
Host: 192.168.24.17
Message: Could not open the haproxy conf file at: '/etc/haproxy/haproxy.cfg'

Failure! The validation failed for all hosts:
* 192.168.24.10
* 192.168.24.17
* 192.168.24.7

Version-Release number of selected component (if applicable):
openstack-tripleo-ui-3.1.0-9.el7ost.noarch


How reproducible:
always

Steps to Reproduce:
1. deploy overcloud
2. run the validation
3.

Actual results:
fails 

Expected results:
passes

Additional info:
on a setup with composable roles the validation shows success but with Warning! The validation did not run on any host.

Comment 4 Udi 2018-05-01 06:25:27 UTC
Verified: openstack-tripleo-validations-8.4.0-2.el7ost.noarch

Comment 6 errata-xmlrpc 2018-06-27 13:29:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.