Bug 144632 - RFE: Obsoletes to include ranges like Provides
RFE: Obsoletes to include ranges like Provides
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 23:29 EST by Jeff Pitman
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-19 22:49:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Pitman 2005-01-09 23:29:08 EST
Obsoletes: foo >= 1.0.1 
Obsoletes: foo < 1.1 
 
This would Obsolete all versions of 1.0.1 to 1.1 exclusive.  Currently, one 
must manually entire all possible existing versions to obsolete, which can be 
cumbersome to deal with.
Comment 1 Jeff Johnson 2005-01-10 09:31:47 EST
This is a couple of hours work and looks to be useful, permitting
a range of EVR to be removed.

Sign off from the python heads for the semnatic change please.
Comment 2 Jeff Johnson 2005-01-10 09:33:57 EST
And rather than opening another bug, another RFE:

I think Obsoletes: should become persistent, treated as
Conflicts: after install.
Comment 3 Paul Nasrat 2005-01-10 10:39:36 EST
Poked appropriate lists
Comment 4 Jeff Johnson 2006-01-19 22:49:37 EST
Nothing heard, over a year.

Note You need to log in before you can comment on or make changes to this bug.