Bug 1446379
| Summary: | openstack-containers: basic overcloud deployment of 1 controller 1 compute with containers fails over " /rootfs/etc/sysconfig/memcached not a directory" | ||
|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | Omri Hochman <ohochman> |
| Component: | openstack-containers | Assignee: | Jiri Stransky <jstransk> |
| Status: | CLOSED ERRATA | QA Contact: | Jaroslav Henner <jhenner> |
| Severity: | urgent | Docs Contact: | Andrew Burden <aburden> |
| Priority: | high | ||
| Version: | 12.0 (Pike) | CC: | jstransk, lruzicka, m.andre, sclewis |
| Target Milestone: | Upstream M2 | Keywords: | Triaged |
| Target Release: | 12.0 (Pike) | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2017-12-13 19:14:33 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Omri Hochman
2017-04-27 19:12:48 UTC
adding the comment from Jirka - " I looked into the machine, there's more errors earlier in the deployment (in puppet) which didn't fail the deployment, but they should. E.g. dub 27 01:11:14 overcloud-controller-0.localdomain os-collect-config[3301]: Digest: sha2565d410080d7328cd3e0f5e7a7cdb0b302337b4e019233bb513e0fb9b7fe36d00 dub 27 01:11:14 overcloud-controller-0.localdomain os-collect-config[3301]: /usr/bin/docker-current: Error response from daemon: linux spec user: unable to find user root: no matching entries in passwd file. dub 27 01:11:14 overcloud-controller-0.localdomain os-collect-config[3301]: Failed running docker-puppet.py for mysql dub 27 01:11:14 overcloud-controller-0.localdomain os-collect-config[3301]: Removing container: docker-puppet-mysql dub 27 01:11:14 overcloud-controller-0.localdomain os-collect-config[3301]: docker-puppet-mt/docker-puppet-memcached.sh: Permission denied dub 27 01:11:14 overcloud-controller-0.localdomain os-collect-config[3301]: Failed running docker-puppet.py for memcached dub 27 01:11:14 overcloud-controller-0.localdomain os-collect-config[3301]: Removing container: docker-puppet-memcached dub 27 01:11:14 overcloud-controller-0.localdomain os-collect-config[3301]: docker-puppet-memcached dub 27 01:11:14 overcloud-controller-0.localdomain os-collect-config[3301]: --------- The tripleo-heat-templates are quite outdated, e.g. we're missing this commit https://github.com/openstack/tripleo-heat-templates/commit/af03e4d34bffcabd26e72eb85137b91f348ee2cb which would fail the deployment on the earlier errors. I'd suggest we update to recent t-h-t before spending additional time debugging the errors. Jirka" We've started to see the same issue in upstream CI. that was the fix : https://review.openstack.org/#/c/467572/1 unable to reproduce with latest osp12 puddles. Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHEA-2017:3457 |