Bug 1446469 - unable to rct cc entitlement cert
Summary: unable to rct cc entitlement cert
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-28 06:59 UTC by Shwetha Kallesh
Modified: 2017-08-01 19:23 UTC (History)
5 users (show)

Fixed In Version: subscription-manager-1.19.11-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:23:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1612 None None None 2017-04-28 14:46:57 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Shwetha Kallesh 2017-04-28 06:59:37 UTC
Description of problem:
unable to rct cc entitlement cert

Version-Release number of selected component (if applicable):
[root@dhcp35-160 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.10-1.git.4.43286fa.el7
python-rhsm: 1.19.5-1.git.51.43286fa.el7


How reproducible:


Steps to Reproduce:


[root@dhcp35-160 ~]# rct cat-cert /etc/pki/entitlement/5404374932589447637.pem 
Traceback (most recent call last):
  File "/usr/bin/rct", line 24, in <module>
    from subscription_manager.i18n import configure_i18n
ImportError: No module named subscription_manager.i18n


Actual results:


Expected results:


Additional info:

Comment 2 Shwetha Kallesh 2017-04-28 10:16:34 UTC
Cannot rct cc even consumer certs

[root@dhcp35-160 ~]# rct cc /etc/pki/consumer/
cert.pem  key.pem   
[root@dhcp35-160 ~]# rct cc /etc/pki/consumer/cert.pem 
Traceback (most recent call last):
  File "/usr/bin/rct", line 24, in <module>
    from subscription_manager.i18n import configure_i18n
ImportError: No module named subscription_manager.i18n

Comment 6 Shwetha Kallesh 2017-05-03 06:23:24 UTC
[root@dhcp71-191 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7


[root@dhcp71-191 ~]# rct cc /etc/pki/consumer/cert.pem 

+-------------------------------------------+
	Identity Certificate
+-------------------------------------------+

Certificate:
	Path: /etc/pki/consumer/cert.pem
	Version: 1.0
	Serial: 3083273667611818905
	Start Date: 2017-05-03 05:41:18+00:00
	End Date: 2018-05-03 05:41:18+00:00
	Alt Name: URI:CN=dhcp71-191.rhts.eng.bos.redhat.com

Subject:
	CN: 16cdb665-857c-4069-afef-7d63e99aa73c

Issuer:
	C: US
	CN: Red Hat Candlepin Authority
	O: Red Hat, Inc.
	OU: Red Hat Network
	ST: North Carolina
	emailAddress: ca-support@redhat.com


[root@dhcp71-191 ~]# rct cc /etc/pki/entitlement/3544434470661296329.pem 

+-------------------------------------------+
	Entitlement Certificate
+-------------------------------------------+

Certificate:
	Path: /etc/pki/entitlement/3544434470661296329.pem
	Version: 3.2
	Serial: 3544434470661296329
	Start Date: 2016-08-21 04:00:00+00:00
	End Date: 2017-08-21 03:59:59+00:00
	Pool ID: 8a99f98a569e675e0156b3206e9f0d72

Subject:
	CN: 8a99f9835ba86ed0015bccd5bc8d303b

Issuer:
	C: US
	CN: Red Hat Candlepin Authority
	O: Red Hat, Inc.
	OU: Red Hat Network
	ST: North Carolina
	emailAddress: ca-support@redhat.com

Product:
	ID: 69
	Name: Red Hat Enterprise Linux Server
	Version: 
	Arch: x86_64,ia64,x86
	Tags: 
	Brand Type: OS
	Brand Name: Red Hat Enterprise Linux

Product:
	ID: 180
	Name: Red Hat Beta
	Version: 
	Arch: x86_64,ppc64le,ppc64,ia64,ppc,x86,s390,s390x
	Tags: 
	Brand Type: 
	Brand Name: 

Product:
	ID: 240
	Name: Oracle Java (for RHEL Server)
	Version: 
	Arch: x86_64,x86
	Tags: 
	Brand Type: 
	Brand Name: 

Order:
	Name: Red Hat Enterprise Linux (Retail Edition)
	Number: 
	SKU: MCT1329
	Contract: 
	Account: 
	Service Level: Basic
	Service Type: L1-L3
	Quantity: 10
	Quantity Used: 1
	Socket Limit: 1
	RAM Limit: 
	Core Limit: 
	Virt Only: False
	Stacking ID: 
	Warning Period: 0
	Provides Management: False

Comment 7 errata-xmlrpc 2017-08-01 19:23:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.