Bug 144647 - up2date randomly crashes, with no helpful error message (python backtrace)
up2date randomly crashes, with no helpful error message (python backtrace)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 04:35 EST by Tore Anderson
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:09:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tore Anderson 2005-01-10 04:35:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
I run the command "up2date --dry-run --update" hourly, saving the output to a file (so that Nagios can parse it and warn if there's pending packages).

This seems to fail randomly, several times a week.  However, when it does happen - it usually happens on several of the machines in the cluster at the same time.  So I suspect the bug isn't neccesarily in up2date itself, but perhaps in the network or in the source servers (I use standard RHN along with some homemade APT repositories).

Regardless I'd call it a bug of up2date to supply such a hopelessly obscure error message - and it's quite annonying to receive dozens of them every week in root's mail. 

Version-Release number of selected component (if applicable):
4.2.57-2

How reproducible:
Sometimes

Steps to Reproduce:
1.  Run up2date --dry-run --update periodically
2.  Wait for it to fail (usually happens within a few days

Actual Results:  It works most of the time, but occasionally it fails with the error message below.

Expected Results:  Should've worked all the time, obviously.

Additional info:

The entire error message:

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1174, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 772, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1066, in batchRun
    batch.run()
  File "up2dateBatch.py", line 62, in run
  File "up2dateBatch.py", line 97, in __findPackagesToUpdate
  File "packageList.py", line 157, in addGlobs
  File "rhnPackageInfo.py", line 232, in getAvailablePackageList
  File "rhnPackageInfo.py", line 150, in availablePackageList
  File "repoDirector.py", line 64, in initRepoDirector
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py", line 345, in register
    up2dateRepo = Up2dateRepo()
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py", line 304, in __init__
    serverSettings)
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py", line 247, in getGETServer
    server= rpcServer.RetryGETServer(serverSettings.serverList.server(),
  File "rpcServer.py", line 104, in server
IndexError: list index out of range
Comment 1 Jack Neely 2005-04-08 10:18:59 EDT
We are seeing this traceback at NCSU as well.  

up2date-4.2.57-2 among other versions

Its the exact same traceback.  With about 500 machines running up2date each
night and sending me any errors that may happen I always get 5 - 10 errors like
this.  Not sure what the pattern is.  In my case this even happens when running
through an RHN Proxy server.

The following bugs are duplicates of this one: 131584 and 146044.

Can we at least get a sane error message here or an explaination to what's
causing this?
Comment 2 RHEL Product and Program Management 2007-10-19 15:09:41 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.