Bug 14465 - NFS Exported directories tab does not cause knfs deamon to start at boot.
NFS Exported directories tab does not cause knfs deamon to start at boot.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-22 14:21 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-07-22 14:21:08 EDT
The linuxconfic  Config->Networking->Server tasks->Exported File Systems
tab modifies fstab but does not configure system to start knfsd at boot. 
This results in the configured directories not be accessible over the
network at bootup until the user manually configures the system to start
knfsd.  Prior to RH 6.2 this was not likely an issue because knfsd was
started automatically, and the result of adding a directory to the list was
that the directory could be accessed via NFS from another machine.  However
RH 6.2 apparently no longer starts knfsd by default.  The reference guide
(http://www.redhat.com/support/manuals/RHL-6.2-Manual/ref-guide/s1-non-inst-new-feat-sysadmin.html)
reads:
I apologize if this turns out to be a duplicate.  I searched for an earlier
bug I put in relative to this several days ago but could not find it.

John Sotack
**********************************************************************
Services no longer run by default:

     To permit a more fine-tuned system configuration, Red Hat Linux 6.2 no
longer runs the following services by default -- 

         The automount daemon amd (in the am-utils RPM) 

         The bind name server 

         The dhcpd DHCP server 

         The inn news server 

------>  The knfsd NFS server <----------------

         The samba CIFS server used to support Windows-based file and print
services 

     To enable these services, either use chkconfig --level 35
<service-name> on, or edit the list of services to start with the
     ntsysv or tksysv utilities.
Comment 1 Brent Fox 2002-06-05 12:23:35 EDT
Closing because we don't ship linuxconf anymore
Comment 2 Red Hat Bugzilla 2006-02-21 13:47:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.