Bug 1446681 - avc: denied { write } for comm="rpc.nfsd" name="nlm_grace_period"
Summary: avc: denied { write } for comm="rpc.nfsd" name="nlm_grace_period"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-28 15:15 UTC by Pat Riehecky
Modified: 2018-10-30 10:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:00:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:01:02 UTC

Description Pat Riehecky 2017-04-28 15:15:02 UTC
Description of problem:
SELinux is preventing /usr/sbin/rpc.nfsd from write access on the file /proc/sys/fs/nfs/nlm_grace_period.

*****  Plugin catchall (100. confidence) suggests   **************************

Additional Information:
Source Context                system_u:system_r:nfsd_t:s0
Target Context                system_u:object_r:sysctl_fs_t:s0
Target Objects                /proc/sys/fs/nfs/nlm_grace_period [ file ]
Source                        rpc.nfsd
Source Path                   /usr/sbin/rpc.nfsd
Port                          <Unknown>
Source RPM Packages           nfs-utils-1.3.0-0.33.el7_3.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-102.el7_3.15.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Platform                      Linux
                              3.10.0-514.10.2.el7.x86_64 #1 SMP Thu Mar 2
                              11:21:24 CST 2017 x86_64 x86_64
Alert Count                   2
First Seen                    2017-04-28 08:46:41 CDT
Last Seen                     2017-04-28 09:59:30 CDT
Local ID                      e51520f8-c325-4509-84ff-d0ff4956cb73

Raw Audit Messages
type=AVC msg=audit(1493391570.707:166): avc:  denied  { write } for  pid=4103 comm="rpc.nfsd" name="nlm_grace_period" dev="proc" ino=34700 scontext=system_u:system_r:nfsd_t:s0 tcontext=system_u:object_r:sysctl_fs_t:s0 tclass=file


type=SYSCALL msg=audit(1493391570.707:166): arch=x86_64 syscall=open success=yes exit=ESRCH a0=7f9d918d2078 a1=1 a2=0 a3=0 items=1 ppid=1 pid=4103 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rpc.nfsd exe=/usr/sbin/rpc.nfsd subj=system_u:system_r:nfsd_t:s0 key=(null)

type=CWD msg=audit(1493391570.707:166): cwd=/var/lib/nfs

type=PATH msg=audit(1493391570.707:166): item=0 name=/proc/sys/fs/nfs/nlm_grace_period inode=34700 dev=00:03 mode=0100644 ouid=0 ogid=0 rdev=00:00 obj=system_u:object_r:sysctl_fs_t:s0 objtype=NORMAL

Hash: rpc.nfsd,nfsd_t,sysctl_fs_t,file,write


Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-102.el7_3.15.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
AVC errors

Expected results:
No errors

Additional info:

Comment 6 errata-xmlrpc 2018-10-30 10:00:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.