Bug 1446688 - Bail out earlier in case of no reserved memory
Summary: Bail out earlier in case of no reserved memory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools
Version: 7.4
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Xunlei Pang
QA Contact: Emma Wu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-28 15:25 UTC by Xunlei Pang
Modified: 2017-08-01 09:33 UTC (History)
6 users (show)

Fixed In Version: kexec-tools-2.0.14-9.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:33:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2300 0 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2017-08-01 12:40:58 UTC

Description Xunlei Pang 2017-04-28 15:25:01 UTC
Description of problem:
Amazon EC2 C5 cloud complained that VM boot speed is slower than Ubuntu and other distributions, after some debugging, people found that one of the causes is kdump service starts slow, although it is parallel, it affects the speed more or less especially on VMs with few cpus, which is unacceptable.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Remove "crashkernel=X"
2. touch /etc/kdump.conf
3. date; kdumpctl start; date (see the elapsed seconds)

Actual results:
kdump service takes a few seconds to finish and fail.
Even more at the first time, because the new kdump initramfs is generated, then kdump service start fail.

Expected results:
bail out eariler without building/checking any initramfs even at the first time.

Additional info:

Comment 6 errata-xmlrpc 2017-08-01 09:33:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2300


Note You need to log in before you can comment on or make changes to this bug.