Bug 1446738 - OSP10 -> OSP11 upgrade fails during compute node upgrade: No such file or directory - /etc/nova/migration/authorized_keys20170428-126080-1p086ep.lock
Summary: OSP10 -> OSP11 upgrade fails during compute node upgrade: No such file or dir...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Emilien Macchi
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-28 17:15 UTC by Marius Cornea
Modified: 2017-05-17 20:24 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-10.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:24:09 UTC


Attachments (Terms of Use)
compute node upgrade log (280.73 KB, text/plain)
2017-04-28 17:16 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 461115 None None None 2017-04-28 17:58:00 UTC
Launchpad 1687081 None None None 2017-04-28 17:56:51 UTC

Description Marius Cornea 2017-04-28 17:15:52 UTC
Description of problem:
OSP10 -> OSP11 upgrade fails during compute node upgrade: No such file or directory - /etc/nova/migration/authorized_keys20170428-126080-1p086ep.lock

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-9.el7ost.noarch
puppet-nova-10.4.0-5.el7ost.noarch

How reproducible:
2/2

Steps to Reproduce:
1. Deploy OSP10
2. Upgrade to OSP11

Actual results:
Compute node upgrade fails during puppet run:

Error: Could not set 'file' on ensure: No such file or directory - /etc/nova/migration/authorized_keys20170428-126080-1p086ep.lock at 189:/etc/puppet/modules/tripleo/manifests/profile/base/nova.pp
Error: Could not set 'file' on ensure: No such file or directory - /etc/nova/migration/authorized_keys20170428-126080-1p086ep.lock at 189:/etc/puppet/modules/tripleo/manifests/profile/base/nova.pp
Wrapped exception:
No such file or directory - /etc/nova/migration/authorized_keys20170428-126080-1p086ep.lock
Error: /Stage[main]/Tripleo::Profile::Base::Nova/File[/etc/nova/migration/authorized_keys]/ensure: change from absent to file failed: Could not set 'file' on ensure: No such file or directory - /etc/nova/migration/authorized_keys20170428-126080-1p086ep.lock at 189:/etc/puppet/modules/tripleo/manifests/profile/base/nova.pp
Error: Could not set 'file' on ensure: No such file or directory - /etc/nova/migration/identity20170428-126080-1h9n9rp.lock at 198:/etc/puppet/modules/tripleo/manifests/profile/base/nova.pp
Error: Could not set 'file' on ensure: No such file or directory - /etc/nova/migration/identity20170428-126080-1h9n9rp.lock at 198:/etc/puppet/modules/tripleo/manifests/profile/base/nova.pp
Wrapped exception:
No such file or directory - /etc/nova/migration/identity20170428-126080-1h9n9rp.lock
Error: /Stage[main]/Tripleo::Profile::Base::Nova/File[/etc/nova/migration/identity]/ensure: change from absent to file failed: Could not set 'file' on ensure: No such file or directory - /etc/nova/migration/identity20170428-126080-1h9n9rp.lock at 198:/etc/puppet/modules/tripleo/manifests/profile/base/nova.pp

Expected results:
Compute node upgrade doesn't fail.

Additional info:
Attaching upgrade-non-controller.sh-overcloud-novacompute-0 log

Comment 1 Marius Cornea 2017-04-28 17:16:39 UTC
Created attachment 1274982 [details]
compute node upgrade log

Comment 2 Ollie Walsh 2017-04-28 17:32:07 UTC
Warning: [norpm] Attempting to install openstack-nova-migration but it will not be installed

Pkg installs are disabled in puppet. Shouldn't they be enabled for upgrade?

Comment 3 Sofer Athlan-Guyot 2017-04-28 17:36:40 UTC
(In reply to Ollie Walsh from comment #2)
> Warning: [norpm] Attempting to install openstack-nova-migration but it will
> not be installed
> 
> Pkg installs are disabled in puppet. Shouldn't they be enabled for upgrade?

No pkg installation is disabled for puppet, you need to add it to step3 of the upgrade like in https://github.com/openstack/tripleo-heat-templates/blob/stable/ocata/puppet/services/nova-placement.yaml#L127..L130

Comment 4 Sofer Athlan-Guyot 2017-04-28 17:43:21 UTC
We need as well to put in the created script https://github.com/openstack/tripleo-heat-templates/blob/stable/ocata/extraconfig/tasks/tripleo_upgrade_node.sh#L53..L54 an it's usually run in batch mode.

Comment 7 errata-xmlrpc 2017-05-17 20:24:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.