Bug 1446813 - [abrt] dnfdragora: module(): __init__.py:192:<module>:GLib.GError: g-io-error-quark: The connection is closed (18)
Summary: [abrt] dnfdragora: module(): __init__.py:192:<module>:GLib.GError: g-io-error...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:494e67f1a126cdae2708c0bc9b8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-29 02:58 UTC by Claudio Rimmele
Modified: 2018-01-01 22:12 UTC (History)
5 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:29:21 UTC


Attachments (Terms of Use)
File: backtrace (11.04 KB, text/plain)
2017-04-29 02:58 UTC, Claudio Rimmele
no flags Details
File: cgroup (355 bytes, text/plain)
2017-04-29 02:58 UTC, Claudio Rimmele
no flags Details
File: cpuinfo (1.29 KB, text/plain)
2017-04-29 02:58 UTC, Claudio Rimmele
no flags Details
File: environ (3.41 KB, text/plain)
2017-04-29 02:58 UTC, Claudio Rimmele
no flags Details
File: mountinfo (3.55 KB, text/plain)
2017-04-29 02:58 UTC, Claudio Rimmele
no flags Details
File: namespaces (102 bytes, text/plain)
2017-04-29 02:58 UTC, Claudio Rimmele
no flags Details
File: open_fds (614 bytes, text/plain)
2017-04-29 02:58 UTC, Claudio Rimmele
no flags Details

Description Claudio Rimmele 2017-04-29 02:58:40 UTC
Version-Release number of selected component:
dnfdragora-1.0.1-1.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora
crash_function: module
exception_type: GLib.GError
executable:     /usr/bin/dnfdragora
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
#1 <module> in /usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py:192
#2 <module> in /usr/bin/dnfdragora:47

Comment 1 Claudio Rimmele 2017-04-29 02:58:47 UTC
Created attachment 1275065 [details]
File: backtrace

Comment 2 Claudio Rimmele 2017-04-29 02:58:49 UTC
Created attachment 1275066 [details]
File: cgroup

Comment 3 Claudio Rimmele 2017-04-29 02:58:51 UTC
Created attachment 1275067 [details]
File: cpuinfo

Comment 4 Claudio Rimmele 2017-04-29 02:58:53 UTC
Created attachment 1275068 [details]
File: environ

Comment 5 Claudio Rimmele 2017-04-29 02:58:55 UTC
Created attachment 1275069 [details]
File: mountinfo

Comment 6 Claudio Rimmele 2017-04-29 02:58:57 UTC
Created attachment 1275070 [details]
File: namespaces

Comment 7 Claudio Rimmele 2017-04-29 02:58:58 UTC
Created attachment 1275071 [details]
File: open_fds

Comment 8 Björn 'besser82' Esser 2017-04-29 08:48:19 UTC
Please don't mark bugs private…

***

This looks like the dnfdaemon-session is lock from the previous failed attempt to start dnfdragora.

Please run `dnfdragora --exit` in terminal and see if it helps.

Comment 9 mindsetice 2017-07-27 23:22:20 UTC
*** Bug 1476042 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2017-12-29 23:25:20 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 11 Fedora Update System 2017-12-29 23:28:53 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 12 Fedora Update System 2017-12-30 19:55:37 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 13 Fedora Update System 2017-12-30 20:41:24 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 14 Fedora Update System 2017-12-31 21:29:21 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2018-01-01 22:12:54 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.