Bug 1446817 - Cannot sign in with new Google sign-in page
Summary: Cannot sign in with new Google sign-in page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: webkitgtk4
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1447054 1448651 1450696 (view as bug list)
Depends On:
Blocks: 1448192
TreeView+ depends on / blocked
 
Reported: 2017-04-29 03:33 UTC by Cesar
Modified: 2017-05-18 20:58 UTC (History)
14 users (show)

Fixed In Version: webkitgtk4-2.16.2-1.fc26 webkitgtk4-2.16.2-1.fc25 webkitgtk4-2.16.2-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-14 20:19:05 UTC
Type: Bug


Attachments (Terms of Use)
Screencasting of the bug (546.92 KB, application/octet-stream)
2017-04-29 03:33 UTC, Cesar
no flags Details
Pocket: Log In with Google doesn't work (22.48 KB, image/png)
2017-04-30 17:01 UTC, Alessio
no flags Details
Trying to log in on Google via Epiphany (22.22 KB, image/png)
2017-05-01 21:30 UTC, Cesar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1448192 unspecified CLOSED Cannot sign in with new Google sign-in page 2020-10-14 00:28:05 UTC
WebKit Project 171770 None None None 2017-05-09 14:10:29 UTC

Internal Links: 1448192

Description Cesar 2017-04-29 03:33:32 UTC
Created attachment 1275108 [details]
Screencasting of the bug

Description of problem:

Google pushed its new login account screen (https://support.google.com/accounts/answer/7338427?co=GENIE.Platform%3DDesktop&hl=en) to my accounts. 
When trying to (re)login, GOA opens a browser window that asks for my email and my password and, instead of the 2FA auth screen or the permissions screen, returns me a blank page.



Version-Release number of selected component (if applicable): 3.22.5-1.fc25.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Open the Settings application
2. Open Online Accounts
3. Add a Google account
4. Enter email and password when asked

Actual results:

Blank screen

Expected results:

A webpage asking for a number from the Authenticator app (for 2FA account) or for permissions (for non-2FA account)

Additional info:

Comment 1 Alessio 2017-04-30 17:01:51 UTC
Created attachment 1275297 [details]
Pocket: Log In with Google doesn't work

Comment 2 Alessio 2017-04-30 17:03:06 UTC
Same thing here.
Even logging in with an already configured account lead me to an empty page.

In addition, with Pocket, when I try to click on "Log In with Google" nothing happens.

Same issues in Fedora 26 Branched 20170420.n.0 Installation

Comment 3 Alessio 2017-04-30 17:08:39 UTC
Googling around, it seems that also a lot of Ubuntu 17.04 and Arch Linux users are experiencing the same issue.

Comment 4 Debarshi Ray 2017-05-01 18:38:43 UTC
I see. Sadly, I checked and Google hasn't pushed the new login screen to my account. Can you log into your Google account using Epiphany?

Comment 5 Cesar 2017-05-01 21:30:08 UTC
Created attachment 1275466 [details]
Trying to log in on Google via Epiphany

Comment 6 Alessio 2017-05-02 10:23:00 UTC
I tried again right now.
Now it works both on F25 and F26.
Maybe a Google side problem?

Comment 7 Cesar 2017-05-02 22:09:13 UTC
(In reply to Alessio from comment #6)
> I tried again right now.
> Now it works both on F25 and F26.
> Maybe a Google side problem?

Still buggy here on F25.

Comment 8 chirox 2017-05-04 18:26:13 UTC
> Still buggy here on F25.

Same here - also F25

Comment 9 Vitor Boufleur 2017-05-05 19:33:37 UTC
Got this bug on a fresh Antergos install. Gnome 3.24.1

Comment 10 Shaun Assam 2017-05-06 23:09:04 UTC
I'm having this issue as well and did a few tests with Fedora 25 Workstation x86_64 as a KVM guest:

1.  Did fresh install of Fedora 25 in VM, did not perform system updates, and tried adding my Google account in Gnome Online Accounts. The new Google authentication screen appeared and after entering my credentials it successfully authenticated and the account appeared in GOA. I tried adding a second Google account; again authentication screen appeared, entered credentials, authentication was successful and the second account appeared in GOA.  At this point both accounts are active and I can view my emails, calendar and contacts in  Evolution as well as files on my Google Drive in Nautilus. Rebooted VM, everything is working as expected.

2.  Performed system updates via "dnf update", GOA upgraded to gnome-online-accounts-3.22.5-1.fc25, and after reboot checked GOA. The second Google account displays a message stating the credentials have expired. Tried authenticating the account and got the blank screen after entering the password. The account still displays the credentials expired message.

3.  Performed "dnf downgrade gnome-online-accounts" to go back to the original GOA package and rebooted. The second account no longer displays the credentials message and is working as expected. Upgraded to gnome-online-accounts-3.22.4-1.fc25 and rebooted. The accounts are active and working as expected. Tried adding the third Google account and got the blank screen after entering the password.

4.  Performed "dnf downgrade gnome-online-accounts" to go back to the original, fresh install, GOA package and rebooted. The Google accounts in GOA are active and working as expected. Tried adding a third Google account and got the blank screen after entering the password. Removed one of the accounts and tried to add it again, but the blank screen appeared.

Based on this info, is it safe to say this is an issue with GOA and other related packages? If this was an issue with Google's new authentication screen, why did authentication pass in part 1?

Comment 11 Shaun Assam 2017-05-08 00:23:04 UTC
After doing some more troubleshooting I've pinpointed the issue to the webkitgtk4 packages. In short, downgrading webkitgtk4 packages to version 2.14.1-2 fixed the GOA Google Authentication issue. Here's a condensed record of that troubleshooting:

- After doing a fresh install of Fedora 25 Workstation x64, and testing Google authentication in GOA (the new login screen appeared and it worked), I made a list of all the packages that required updating by doing: dnf check-update >> updates.txt. I then disabled the updates repo.

- I updated Evolution, GDM and all GNOME-named packages, including gnome-online-accounts with: dnf --enablerepo=updates update evolution* gdm gnome*; reboot.

- System successfully booted. I tried adding my second Google account in GOA; everything worked as expected and my Google account appeared in the GOA list. I rebooted to make sure I didn't get the Credentials Expired error. Both accounts were in the list and everything working as it should. I removed the second Google account from GOA.

- Going back to the Terminal, I updated the webkitgtk4, webkitgtk4-jsc, and webkitgtk4-plugin-process-gtk2 packages to latest version (webkitgtk4-2.16.1-2.fc25) and rebooted.

- After login I checked GOA and saw the error about my credentials being expired. I tried authenticating that account and got the blank screen. I tried my second Google account and got the blank screen. I removed the second account, leaving the credentials expired account and downgraded the packages back to version 2.14.1-2.fc25 with: dnf downgrade webkitgtk4*.

- After reboot the account no longer had the credentials expired error and the second Google account successfully authenticated. Rebooted; both accounts are active and working 100%.

- Upgraded to webkitgtk4-2.14.5-1 and rebooted. GOA shows no errors regarding expired credentials. Removed the second Google account and tried adding it again; got the blank screen. Downgraded back to 2.14.1-2, rebooted and GOA successfully added the second account. Both Google accounts are in the GOA list and working as expected.

- Added webkitgtk4* to the exclude list in fedora-updates.repo file, performed the rest of the system updates and rebooted. GOA working as expected and no blank screens during Google authentication.

Comment 12 David Ward 2017-05-08 03:37:08 UTC
Reportedly fixed upstream in webkit:
https://bugs.webkit.org/show_bug.cgi?id=171770

Patch: http://trac.webkit.org/changeset/216343

Comment 13 Michael Catanzaro 2017-05-08 14:22:02 UTC
We'll prepare an update ASAP.

Comment 14 Debarshi Ray 2017-05-09 14:13:01 UTC
*** Bug 1448651 has been marked as a duplicate of this bug. ***

Comment 15 Debarshi Ray 2017-05-09 14:14:32 UTC
*** Bug 1447054 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2017-05-10 02:57:42 UTC
webkitgtk4-2.16.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2c2c2032c0

Comment 17 Fedora Update System 2017-05-10 02:57:55 UTC
webkitgtk4-2.16.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c8a78c882a

Comment 18 Fedora Update System 2017-05-10 02:58:03 UTC
webkitgtk4-2.16.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3fa1357529

Comment 19 Cesar 2017-05-10 22:55:25 UTC
Installed manually the webkitgtk4-2.16.2-1 packages, solved the bug! Thank you for the quick response! Hope it goes to update soon!

Comment 20 Stephane Konstantaropoulos 2017-05-11 18:52:29 UTC
I can confirm that the webkit (webkitgtk4-2.16.2-1) fix works too.

Comment 21 Fedora Update System 2017-05-12 13:35:09 UTC
webkitgtk4-2.16.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c8a78c882a

Comment 22 Fedora Update System 2017-05-12 22:33:23 UTC
webkitgtk4-2.16.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3fa1357529

Comment 23 Fedora Update System 2017-05-13 01:09:12 UTC
webkitgtk4-2.16.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2c2c2032c0

Comment 24 Fedora Update System 2017-05-14 20:19:05 UTC
webkitgtk4-2.16.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2017-05-15 04:35:57 UTC
webkitgtk4-2.16.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Debarshi Ray 2017-05-15 12:12:08 UTC
*** Bug 1450696 has been marked as a duplicate of this bug. ***

Comment 27 Fedora Update System 2017-05-18 20:58:52 UTC
webkitgtk4-2.16.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.