Bug 1446819 - [abrt] dnfdragora: __gnu_cxx::__verbose_terminate_handler()(): python3.6 killed by signal 6
Summary: [abrt] dnfdragora: __gnu_cxx::__verbose_terminate_handler()(): python3.6 kill...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:14299870f1df63366fa6dcaae6c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-29 03:56 UTC by Claudio Rimmele
Modified: 2018-01-01 22:12 UTC (History)
5 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:29:25 UTC


Attachments (Terms of Use)
File: backtrace (88.21 KB, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: cgroup (289 bytes, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: core_backtrace (15.51 KB, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: cpuinfo (1.29 KB, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: dso_list (18.36 KB, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: environ (1.74 KB, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: limits (1.29 KB, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: maps (52.65 KB, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: open_fds (678 bytes, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: proc_pid_status (1.25 KB, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
File: var_log_messages (28 bytes, text/plain)
2017-04-29 03:57 UTC, Claudio Rimmele
no flags Details
Output of $ LC_ALL=C dnfdragora > dnfdragora-log.txt (3.94 KB, text/plain)
2017-05-14 13:52 UTC, Christian Stadelmann
no flags Details

Description Claudio Rimmele 2017-04-29 03:56:59 UTC
Version-Release number of selected component:
dnfdragora-1.0.1-1.fc26

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora
crash_function: __gnu_cxx::__verbose_terminate_handler()
executable:     /usr/bin/python3.6
journald_cursor: s=6eff262bc93a4d7fb688b7252e86fec6;i=1e18c;b=d9494cdadf8b4ff19f3444b04890d6fa;m=b44ab9e5;t=54e461b5307f4;x=d99c7700295f498b
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Claudio Rimmele 2017-04-29 03:57:08 UTC
Created attachment 1275121 [details]
File: backtrace

Comment 2 Claudio Rimmele 2017-04-29 03:57:10 UTC
Created attachment 1275122 [details]
File: cgroup

Comment 3 Claudio Rimmele 2017-04-29 03:57:13 UTC
Created attachment 1275123 [details]
File: core_backtrace

Comment 4 Claudio Rimmele 2017-04-29 03:57:15 UTC
Created attachment 1275124 [details]
File: cpuinfo

Comment 5 Claudio Rimmele 2017-04-29 03:57:17 UTC
Created attachment 1275125 [details]
File: dso_list

Comment 6 Claudio Rimmele 2017-04-29 03:57:19 UTC
Created attachment 1275126 [details]
File: environ

Comment 7 Claudio Rimmele 2017-04-29 03:57:21 UTC
Created attachment 1275127 [details]
File: limits

Comment 8 Claudio Rimmele 2017-04-29 03:57:24 UTC
Created attachment 1275128 [details]
File: maps

Comment 9 Claudio Rimmele 2017-04-29 03:57:26 UTC
Created attachment 1275129 [details]
File: open_fds

Comment 10 Claudio Rimmele 2017-04-29 03:57:28 UTC
Created attachment 1275130 [details]
File: proc_pid_status

Comment 11 Claudio Rimmele 2017-04-29 03:57:30 UTC
Created attachment 1275131 [details]
File: var_log_messages

Comment 12 Björn 'besser82' Esser 2017-04-29 08:44:45 UTC
Please don't mark bugs private…

***

I need a bit more information about the circumstances:

  1. Looking at the backtrace, it looks like libyui cannot load any usable
     UI-plugin…
  2. How can you reproduce it?
  3. Does it work in terminal?
  4. What happenes when starting from the graphical environment?
  5. Which packages are installed? (sudo dnf info 'dnfdragora*' 'libyui*')

Comment 13 Christian Stadelmann 2017-05-14 13:52:32 UTC
Created attachment 1278666 [details]
Output of $ LC_ALL=C dnfdragora > dnfdragora-log.txt

(In reply to Björn "besser82" Esser from comment #12)
> Please don't mark bugs private…

Maybe the reporter does not want to share all the data publicly?

> I need a bit more information about the circumstances:

I am running into the same crasher (according to abrt), so I hope I can be helpful

>   1. Looking at the backtrace, it looks like libyui cannot load any usable
>      UI-plugin…


>   2. How can you reproduce it?

Start dnfdragora. Nothing more.

>   3. Does it work in terminal?

Yes, at least with $ dnfdragora --ncurses

>   4. What happenes when starting from the graphical environment?

immediate crash on GNOME (my graphical environment).
When started as
$ dnfdragora --qt
it runs fine.

>   5. Which packages are installed? (sudo dnf info 'dnfdragora*' 'libyui*')

$ dnf list installed dnfdragora\*
dnfdragora.noarch         1.0.1-5.git20170505.2a3b056.fc26         @@commandline
$ dnf list installed libyui\*
libyui.x86_64                3.3.2-2.fc26                          @@commandline
libyui-gtk.x86_64            2.44.9-2.fc26                         @@commandline
libyui-mga.x86_64            1.0.8-0.7.gita6a160e.20160313.fc26    @@commandline
libyui-mga-ncurses.x86_64    1.0.2-0.8.git026f2e6.20131215.fc26    @@commandline
libyui-mga-qt.x86_64         1.0.3-0.8.gitb508e88.20140119.fc26    @@commandline
libyui-ncurses.x86_64        2.48.1-4.fc26                         @@commandline
libyui-qt.x86_64             2.47.1-4.fc26                         @@commandline


Workaround:
install libyui-mga-gtk, then the crasher is gone.

So it seems like there are 2 bugs here:
1. packaging: if libyui-gtk can't start on GNOME without libyui-mga-gtk, the latter must be pulled in as dependency. Since I can remove libyui-mga-gtk, the dependency is missing.
2. if libyui fails to init the Gtk backend, it should try the qt backend instead.

Comment 14 Fedora Update System 2017-12-29 23:25:27 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 15 Fedora Update System 2017-12-29 23:28:57 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 16 Fedora Update System 2017-12-30 19:55:41 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 17 Fedora Update System 2017-12-30 20:41:28 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 18 Fedora Update System 2017-12-31 21:29:25 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2018-01-01 22:12:57 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.