Bug 144700 - ctrl-e [end-of-line] command doesn't work in mozilla when text=numbers
ctrl-e [end-of-line] command doesn't work in mozilla when text=numbers
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 14:31 EST by Satish Balay
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 10:54:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2005-01-10 14:31:25 EST
Description of problem:

Wen typing in numbers [whereever mozilla accepts text input] emacs keybindings
misbehave. Esp: Ctrl-E & Ctrl-K

Version-Release number of selected component (if applicable):

mozilla-1.7.5-3
gtk2-2.4.14-2.fc3

How reproducible:
Always

Steps to Reproduce:
1. install FC3 & update mozilla from rawhide (or just install rawhide)
2. enable emacs style editing in by adding the following to ~/.gtkrc-2.0

include "/usr/share/themes/Emacs/gtk-2.0-key/gtkrc"
gtk-key-theme-name = "Emacs"

3. start up mozilla
4. Now get to some 'editable' area  [Ctrl-L to type in a URL will do]
5. Now type in just numbers - say '123'

Actual results: 
Ctrl-A works
Arrow -> works
Ctrl-E  doesn't work
Ctrl-K   kills 'char' instead of 'line'
Moving the 'cursor' to the end of the line with 'mouse' doesn't work

Expected results:
Ctrl-E (end of line) should work
Ctrl-k (kill line) should work
moving Mouse pointer to end of line should work

Additional info:

This is probably gtk bug - but I'm filing against mozilla - as I notice this
here. I see the same issue with 'firefox'
Comment 1 Satish Balay 2005-01-11 14:29:31 EST
Just tried gtk2-2.6.1-1 update in rawhide - still the same behavior. 
Comment 2 Matěj Cepl 2007-03-14 10:54:44 EDT
Since this bugzilla report was filed, there have been several major updates,
which may have resolved this issue, and Mozilla itself was removed from the
latest Fedora Core/RHEL distributions. Users who have experienced this problem
are encouraged to upgrade their system to the latest version of the equivalent
package (Firefox, Thunderbird, etc.) available. Therefore closing this bug as
obsolete.

If you experience this problem on the up-to-date system, please reopen this bug
with an additional information.

Note You need to log in before you can comment on or make changes to this bug.