Bug 144701 - RHEL v3 specific network connection problems over IPv6 across Cisco vlans
RHEL v3 specific network connection problems over IPv6 across Cisco vlans
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Miller
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 14:41 EST by Lee Whatley
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:09:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Whatley 2005-01-10 14:41:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
I am experiencing problems connecting from RHEL v3 to any other RHEL
v3 machine over IPv6 when the machines in question are on different
vlans.  The vlans in question are on the same physical Cisco switch
(don't know if that matters) and the network is currently configured
for IPv4/IPv6 dual-stack.  I have experienced this problem when trying
to use several different applications (our own version of ssh and
ktelnet/krcp, etc), but for the sake of this bug I will just discuss
telnet, since it is included with RHEL v3.

Specifically, the problem is that I can telnet from a RHEL v3 machine
to another RHEL v3 machine without any problems over IPv4.  If I try
to telnet from a RHEL v3 machine to another RHEL v3 machine over IPv6
the client "hangs" after I have authenticated (i.e. I never get a
shell prompt).  

IPv6 connections work fine when the two RHEL machines are on the same
vlan.  Also, ping6, traceroute6, and DNS requests over IPv6 seem to
all work fine regardless of what vlans the machines are on.  I can
telnet over IPv6 between Linux and Solaris machines, that is, the
problem only exists when going from a RHEL machine to another RHEL
machine.

Version-Release number of selected component (if applicable):
kernel-2.4.21-27.0.1.EL

How reproducible:
Always

Steps to Reproduce:
1. Put two RHEL machines on different vlans on a Cisco switch.
2. Make sure each machine gets an IPv6 address
3. Telnet from one machine to the IPv6 address of the other machine
(you can also use the hostname if that hostname has properly
configured AAAA records)
4. Enter your username and then your password
    

Actual Results:  You are properly authenticated and the client sees
the "last connected..." message.  Then instead of getting a shell
prompt the client just sits there until you terminate the process.

Expected Results:  After authenticating you should get a shell.

Additional info:
Comment 1 Lee Whatley 2005-02-01 09:40:34 EST
Anyone had a chance to look at this yet?
Comment 2 Lee Whatley 2005-02-18 12:45:03 EST
*PING*
Comment 3 Lee Whatley 2005-03-08 11:18:38 EST
UPDATE:  After doing further testing...I have found more specific
information about the problem.  The problem only happens when machines
with MTU's set to 1500 are on vlans that have a maximum MTU size of
9180 (i.e. jumbo frame support).  If the maximum MTU size of the vlan
is bumped down to 1500 the problem goes away.

Now the question is:  Is this a redhat-specific bug, a linux-specific
bug, a cisco-specific bug, or an inherent "feature" of IPv6 itself?

Has anyone at redhat even looked at this yet??????
Comment 4 RHEL Product and Program Management 2007-10-19 15:09:31 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.