Bug 144708 - rdoc/parsers/parse_rb.rb references missing irb/slex.rb
rdoc/parsers/parse_rb.rb references missing irb/slex.rb
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 16:20 EST by Carsten Clasohm
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.8.2-1.FC3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 03:04:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carsten Clasohm 2005-01-10 16:20:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
On line 18, the file /usr/lib/ruby/1.8/rdoc/parsers/parse_rb.rb
references "irb/slex", which is not contained in the ruby-libs RPM.
When installing Ruby 1.8.2 from the source, this file is present in
/usr/local/lib/ruby/1.8/irb/slex.rb.


Version-Release number of selected component (if applicable):
ruby-libs-1.8.2-1.FC3.0

How reproducible:
Always

Steps to Reproduce:
1. up2date ruby

2. Download and install rubygems 0.8.1 from the source.

3. Run "gem install rails"


Actual Results: 
/usr/lib/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `require__':
No such file to load -- irb/slex (LoadError)
        from /usr/lib/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
`require'
        from /usr/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:18
        from /usr/lib/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
`require__'
        from /usr/lib/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
`require'
        from /usr/lib/ruby/1.8/rdoc/rdoc.rb:8
        from /usr/lib/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
`require__'
        from /usr/lib/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
`require'
        from /usr/lib/site_ruby/1.8/rubygems/doc_manager.rb:42:in
`generate_rdoc'
        from /usr/lib/site_ruby/1.8/rubygems/gem_commands.rb:167:in
`execute'
        from /usr/lib/site_ruby/1.8/rubygems/gem_commands.rb:166:in `each'
        from /usr/lib/site_ruby/1.8/rubygems/gem_commands.rb:166:in
`execute'
        from /usr/lib/site_ruby/1.8/rubygems/command.rb:49:in `invoke'
        from /usr/lib/site_ruby/1.8/rubygems/cmd_manager.rb:90:in
`process_args'        from
/usr/lib/site_ruby/1.8/rubygems/cmd_manager.rb:63:in `run'
        from /usr/lib/site_ruby/1.8/rubygems/gem_runner.rb:9:in `run'
        from /usr/bin/gem:11


Additional info:
Comment 1 Akira TAGOH 2005-01-26 01:45:58 EST
will be fixed in 1.8.2-3. you need to install rdoc package which separated out.
hopefully the updated package for FC3 will be available soon.
Comment 2 Carsten Clasohm 2005-01-30 09:11:36 EST
Actually, the file is not in the rdoc package, but in
irb-1.8.2-1.FC3.0. When I install this, everythings works fine.

But a file from the ruby-libs-1.8.2-1.FC3.0 RPM should not reference a
file from a different RPM without this being reflected in the RPM
dependency information.
Comment 3 Akira TAGOH 2005-01-30 22:59:35 EST
Yes, that's right. I mean I didn't want to make the dependency of
ruby-libs to irb for this issue. so you will need to install rdoc (and
irb which it requires) for rubygems in the next release of ruby package.
Comment 4 Akira TAGOH 2005-02-07 03:04:42 EST
should be fixed in 1.8.2-1.FC3.1 which is now available for the updates.

Note You need to log in before you can comment on or make changes to this bug.