Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: When the request config_info contains both new_dialog_name and dialog_id, the update process will fail with error dialog already exists. The cause is we will try to create a new service dialog even if the dialog_id is already given. The fix should be using the given dialog_id and ignore the dialog name. This problem was discovered while using rails console to test the update. OPS UI does not have the issue. The fix is more preventive if the config_info comes from a REST API happens to contains both attributes. Version-Release number of selected component (if applicable): How reproducible: Steps to Reproduce: 1. 2. 3. Actual results: Expected results: Additional info:
https://github.com/ManageIQ/manageiq/pull/14958
New commit detected on ManageIQ/manageiq/master: https://github.com/ManageIQ/manageiq/commit/ee74ab4cea7cb1f4581e95859c49f7ba5922a79c commit ee74ab4cea7cb1f4581e95859c49f7ba5922a79c Author: Bill Wei <bilwei> AuthorDate: Mon May 1 16:55:06 2017 -0400 Commit: Bill Wei <bilwei> CommitDate: Mon May 1 16:58:22 2017 -0400 Prefer :dialog_id to :new_dialog_name in config_info https://bugzilla.redhat.com/show_bug.cgi?id=1447110 app/models/service_template_ansible_playbook.rb | 13 +++++++------ spec/models/service_template_ansible_playbook_spec.rb | 9 ++++----- 2 files changed, 11 insertions(+), 11 deletions(-)
Verified in 5.9.0.2.20171010190026_0413a06.