Bug 144720 - Pinfo doesnt display gdb info page correctly, and other problems
Pinfo doesnt display gdb info page correctly, and other problems
Status: CLOSED CURRENTRELEASE
Product: Fedora Legacy
Classification: Retired
Component: pinfo (Show other bugs)
unspecified
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-01-10 17:20 EST by Paul Jakma
Modified: 2007-04-18 13:18 EDT (History)
0 users

See Also:
Fixed In Version: pinfo-0.6.8-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 06:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Jakma 2005-01-10 17:20:56 EST
Description of problem:

The command 'pinfo gdb' brings one straight into the 'Summary of GDB'
node of the GDB docs. The up command doesnt bring one to the menu for
gdb, there doesnt appear to be any way to get to it.

If one types 'gIndex' - the Index displayed looks funny, doesnt appear
to have been parsed correctly, not hyperlinked. 

If one installs the 'quagga' package, types 'pinfo quagga' and goes to
'Command Index' from the menu and then follows any of the links, pinfo
crashes. Ditto with any link in the 'VTY Key Index' node.

The GNU info browser doesnt have any problems.

Version-Release number of selected component (if applicable):

0.6.8-7

How reproducible:

100%

Steps to Reproduce:
1. pinfo gdb
2. pinfo quagga, go to 'Command Index' node and try follow a link
3.
  
Actual results:

Wrong node displayed on startup, crashes, incorrectly presented nodes..

Expected results:

- No crashes
- Get Top node when opening a particular set of info pages.
- Nodes displayed correctly

Additional info:
Comment 1 Mike A. Harris 2005-03-29 09:59:23 EST
I just typed "pinfo gdb" in a shell and got:

File: gdb.info,  Node: Top,  Next: Summary,  Prev: (dir),  Up: (dir)

Debugging with GDB
******************

   This file describes GDB, the GNU symbolic debugger.

   This is the Ninth Edition, for GDB Version Red Hat Linux
(5.3.90-0.20030710.41rh).

   Copyright (C) 1988-2003 Free Software Foundation, Inc.

* Menu:

* Summary::                     Summary of GDB
* Sample Session::              A sample GDB session

* Invocation::                  Getting in and out of GDB
* Commands::                    GDB commands
* Running::                     Running programs under GDB
* Stopping::                    Stopping and continuing
* Stack::                       Examining the stack
* Source::                      Examining source files
* Data::                        Examining data
* Macros::                      Preprocessor Macros
* Tracepoints::                 Debugging remote targets non-intrusively
* Overlays::                    Debugging programs that use overlays

* Languages::                   Using GDB with different languages

* Symbols::                     Examining the symbol table
* Altering::                    Altering execution
* GDB Files::                   GDB files
* Targets::                     Specifying a debugging target
* Remote Debugging::            Debugging remote programs
* Configurations::              Configuration-specific information
* Controlling GDB::             Controlling GDB
* Sequences::                   Canned sequences of commands
* TUI::                         GDB Text User Interface
* Interpreters::                Command Interpreters
* Emacs::                       Using GDB under GNU Emacs
* Annotations::                 GDB's annotation interface.
* GDB/MI::                      GDB's Machine Interface.

* GDB Bugs::                    Reporting bugs in GDB
* Formatting Documentation::    How to format and print GDB documentation

* Command Line Editing::        Command Line Editing
* Using History Interactively:: Using History Interactively
* Installing GDB::              Installing GDB
* Maintenance Commands::        Maintenance Commands
* Remote Protocol::             GDB Remote Serial Protocol
* Agent Expressions::           The GDB Agent Expression Mechanism
* Copying::                     GNU General Public License says
                                how you can copy and share GDB
* GNU Free Documentation License::  The license for this documentation
Viewing line 56/58, 96%


From the above, pinfo is working fine reading the gdb info page for me.

We'll need you to provide more information on how to reproduce this by
troubleshooting this further, and providing detailed steps to reproduce
including your shell, i18n settings, exact configuration/options, etc.
as it's possible it is a problem specific to your exact setup, but not
reproduceable to everyone.  It's also recommended that you report the
problem to the pinfo author, in case he's aware of any issues already,
as he might be able to suggest a fix quicker.

Hope this helps.



Comment 2 Paul Jakma 2005-03-29 10:35:54 EST
It occurs for me with:

[paul@sheen bgpd]$ echo $LANG
en_IE.UTF-8
[paul@sheen bgpd]$ rpm -q pinfo
pinfo-0.6.8-7
[paul@sheen bgpd]$ rpm -q gdb
gdb-6.1post-1.20040607.43

Did you try the same version of gdb? The info page may be different.

Also, did you try navigating through the index? pinfo in Fedora seems to have
problems following links in info indexes for most info pages i've tried (not
just gdb). Index pages are often messed up, or if not, pinfo aborts if you try
to follow a link in the index with a glibc message I can't c&p due to the
terminal being screwed up, but it goes something like:

*** glibc detected *** free(): invalid next size (normal): 0x....... ***
AbortedIndex

I would report this upstream if this appeared to be an upstream problem, however
it appears to be a Fedora specific problem. Pinfo on Debian Sarge (current and
back to original problem report date) does *not* do this for me, and Sarge has
the same upstream version of pinfo (but without the htmlview patch).

I'll try building a pinfo without the htmlview patch, to see if that helps in
narrowing this down.
Comment 3 Paul Jakma 2005-03-29 10:40:07 EST
Ok, it's not the htmlview patch.

problems also remain if I run 'LANG=C pinfo'.
Comment 4 Paul Jakma 2005-03-29 10:42:56 EST
It occurs with pinfo compiled from pristine upstream source too. So it is indeed
an upstream problem.
Comment 5 Mike A. Harris 2005-03-29 11:43:55 EST
Someone pointed out to me in IRC that I didn't do exactly what you mentioned
in the first comment.  I did actually, but my comment wasn't clear about
it.  ;o)

So, just as a datapoint, I was able to bring up the index fine, I also
surfed around through different pages, etc. and it all seems to work
ok for me:



File: gdb.info,  Node: Index,  Prev: GNU Free Documentation License,  Up: Top

Index
*****

* Menu:

* ! packet:                              Packets.
* "No symbol "foo" in current context":  Variables.
* # (a comment):                         Command Syntax.
* # in Modula-2:                         GDB/M2.
* $:                                     Value History.
* $$:                                    Value History.
* $_ and info breakpoints:               Set Breaks.
* $_ and info line:                      Machine Code.
* $_, $__, and value history:            Memory.
* $_, convenience variable:              Convenience Vars.
* $__, convenience variable:             Convenience Vars.

...


Hope this helps.
Comment 6 Paul Jakma 2005-03-29 12:34:09 EST
It appears to be the info page included with Fedora gdb (did you have the
current updated version of gdb installed?), if i copy the FC version to a debian
Sarge machine:

$ INFOPATH=/var/tmp pinfo gdb
<same thing>
# rpm -qf /usr/share/info/gdb.info.gz 
gdb-6.1post-1.20040607.43

The index browsing problems are only repeatable on certain info pages. Eg,
autoconf page - works. Automake doesnt:
# rpm -q automake
automake-1.9.2-3
# pinfo automake
gGeneral Index
<left arrow into 'General Operation'>
<boom - aforementioned glibc error>

Sure you're trying with the current version of gdb in updates? Cause it's
consistently reproduceable here on FC3, across several machines.

Comment 7 Mike A. Harris 2005-03-29 12:48:43 EST
It appears from what you've said above, that there might indeed be a
pinfo bug at play here, and glibc FORTIFY_SOURCE is detecting it.  Either
way, it would be a pinfo bug, and not a problem specific to Fedora Core.

Debian does not use modern gcc/glibc with FORTIFY_SOURCE, and so if pinfo
has a bug in it that FORTIFY_SOURCE can detect, the bug will exist on
Debian (or other) systems, but their glibc just will not inform you of it.

I'm reopening this for now so it'll continue to be tracked now that we
have more information, but it is still an upstream issue, not specific
to Fedora Core, even though you might only see it on Fedora Core until
other OS's start using new gcc/glibc with their enhanced security features,
if this is indeed the problem.

I strongly recommend reporting this to the pinfo maintainer directly also,
to maximize the chances of reproduceability and a sooner fix, if it does
turn out to be a pinfo bug brought to surface by FORTIFY_SOURCE.

Hope this helps...  reopening.

Comment 8 Paul Jakma 2005-03-29 14:08:35 EST
I'll look into FORTIFY_SOURCE, never heard about that before. I'll try look into
that.

Regarding the gdb info page problem - can you confirm you are indeed using
FC3+updates, rather than the gdb package supplied with the original FC3? Cause
there is a problem either in the info page supplied in
gdb-6.1post-1.20040607.43, or possibly even in the texinfo package which
generated that info page. (I happen to see similar problems with other info
pages, some which I have generated - not FC3 packages).

Can you confirm the gdb package version with which not have any problems with
its info page and pinfo?
Comment 10 Mike A. Harris 2006-01-17 19:25:38 EST
Fedora Core 3 has been transferred to the Fedora Legacy project.  Reassigning
bug...
Comment 11 Paul Jakma 2006-01-18 06:18:05 EST
The bug appears to have been fixed in the meantime. At least I havn't noticed it
recently with FC4. Closing.

Note You need to log in before you can comment on or make changes to this bug.