Bug 1447211 - Unable to read cache: /var/lib/rhsm/cache/written_overrides.json
Summary: Unable to read cache: /var/lib/rhsm/cache/written_overrides.json
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-02 06:36 UTC by Wei Liu
Modified: 2017-08-01 19:23 UTC (History)
5 users (show)

Fixed In Version: subscription-manager-1.19.14-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:23:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
The rhsm log (22.43 KB, text/plain)
2017-05-02 06:36 UTC, Wei Liu
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1622 None closed 1447211: Don't try to read non-existing json cache file. 2020-08-25 06:58:57 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Wei Liu 2017-05-02 06:36:56 UTC
Created attachment 1275571 [details]
The rhsm log

Description of problem:
Error message append to rhsm.log when try to register a system and auto-attach:

2017-05-02 13:53:23,154 [ERROR] subscription-manager-gui:5014:FindServiceLevelsThread @cache.py:131 - Unable to read cache: /var/lib/rhsm/cache/written_overrides.json

Version-Release number of selected component (if applicable):
[root@dhcp-128-20 rhsm]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.9-1.el7
python-rhsm: 1.19.5-1.el7

How reproducible:
always

Steps to Reproduce:
1.Install build RHEL-7.4-20170426.4
2.Open subscription-manager gui to register system and click auto-attach subscription
3.Check the rhsm.log and there is an error message
[root@dhcp-128-20 rhsm]# cat rhsm.log | grep -i "error"
2017-05-02 13:52:51,418 [WARNING] subscription-manager-gui:5014:RegisterConsumerThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-02 13:53:23,154 [ERROR] subscription-manager-gui:5014:FindServiceLevelsThread @cache.py:131 - Unable to read cache: /var/lib/rhsm/cache/written_overrides.json    <--------
2017-05-02 13:53:24,817 [WARNING] subscription-manager-gui:5014:FindServiceLevelsThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found

Actual results:
As step3.

Expected results:
NO error message.Register system and auto-attach subscription successfully

Additional info:

Comment 3 Wei Liu 2017-05-18 02:36:49 UTC
Will verify this issue when the new build comes.

Comment 4 Shwetha Kallesh 2017-05-18 11:30:36 UTC
Reproducer:
See the error in the log when click on auto-attach button of GUI

[root@dhcp71-112 ~]# tail -f /var/log/rhsm/rhsm.log | grep ERROR
2017-05-18 03:48:59,074 [ERROR] subscription-manager-gui:15950:FindServiceLevelsThread @cache.py:131 - Unable to read cache: /var/lib/rhsm/cache/written_overrides.json

[root@dhcp71-112 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.23-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7


Verification:
No error message when I register and click on auto-attach button on GUI

[root@dhcp71-112 ~]# tail -f /var/log/rhsm/rhsm.log | grep ERROR

[root@dhcp71-112 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.23-1
subscription management rules: 5.15.1
subscription-manager: 1.19.14-1.el7
python-rhsm: 1.19.6-1.el7

Comment 5 errata-xmlrpc 2017-08-01 19:23:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.