Bug 1447250 - oc rollout status --request-timeout=0 times out
Summary: oc rollout status --request-timeout=0 times out
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: 4.1.0
Assignee: Tomáš Nožička
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-02 08:41 UTC by Paul Dwyer
Modified: 2019-09-05 12:39 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:28 UTC

Description Paul Dwyer 2017-05-02 08:41:01 UTC
Description of problem:
oc rollout status --request-timeout=0 times out

Version-Release number of selected component (if applicable):
OSCP 3.4


How reproducible:
not deterministic, random intervals


Actual results:
oc rollout status command appears to time out with the following error
F0427 09:17:55.700614     118 helpers.go:115] error: timed out waiting for the condition

Expected results:
When using "--request-timeout=0" oc rollout status should not return until deployment has completed

Additional info:
This appears to match upstream issue
https://github.com/kubernetes/kubernetes/issues/40224

This is being seen as part of jenkins pipeline job

Comment 5 Derek Carr 2017-05-05 21:17:26 UTC
fabiano - see related cli issue here: https://github.com/kubernetes/kubernetes/issues/40224

Comment 24 Michal Fojtik 2018-05-10 11:44:50 UTC
Moving this to 3.11 release as the changes in upstream are significant and we unlikely be able to backport this to 3.10. Also this is not a regression, as this had been broken since 3.4.

Comment 25 Tomáš Nožička 2018-08-24 10:37:22 UTC
apimachinery fixed with: https://github.com/kubernetes/kubernetes/pull/66971

upstream fix for rollout status: https://github.com/kubernetes/kubernetes/pull/67817

Comment 26 Tomáš Nožička 2018-09-04 11:58:11 UTC
upstream PR is merged, this will come with 1.12 rebase

Comment 27 zhou ying 2019-02-12 08:58:31 UTC
Confirmed with latest origin, can't reproduce it : 

[root@dhcp-140-138 ~]# oc get clusterversion
NAME      VERSION                           AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.alpha-2019-02-11-201342   True        False         5m10s   Cluster version is 4.0.0-0.alpha-2019-02-11-201342

[root@dhcp-140-138 ~]# oc rollout status --request-timeout=0 dc/nodejs-mongodb-example
Deployment config "nodejs-mongodb-example" waiting on image update
W0212 16:26:05.047455    8251 reflector.go:270] k8s.io/client-go/tools/watch/informerwatcher.go:110: watch of *unstructured.Unstructured ended with: very short watch: k8s.io/client-go/tools/watch/informerwatcher.go:110: Unexpected watch close - watch lasted less than a second and no items received
Deployment config "nodejs-mongodb-example" waiting on image update
W0212 16:40:19.304936    8251 reflector.go:270] k8s.io/client-go/tools/watch/informerwatcher.go:110: watch of *unstructured.Unstructured ended with: very short watch: k8s.io/client-go/tools/watch/informerwatcher.go:110: Unexpected watch close - watch lasted less than a second and no items received
Deployment config "nodejs-mongodb-example" waiting on image update
Waiting for latest deployment config spec to be observed by the controller loop...
Waiting for rollout to finish: 0 out of 1 new replicas have been updated...
Waiting for rollout to finish: 0 out of 1 new replicas have been updated...
Waiting for rollout to finish: 0 out of 1 new replicas have been updated...
Waiting for rollout to finish: 0 of 1 updated replicas are available...
Waiting for latest deployment config spec to be observed by the controller loop...
replication controller "nodejs-mongodb-example-1" successfully rolled out
[root@dhcp-140-138 ~]# oc get po 
NAME                              READY   STATUS      RESTARTS   AGE
jenkins-1-5xx4z                   1/1     Running     0          86m
jenkins-1-deploy                  0/1     Completed   0          87m
mongodb-1-deploy                  0/1     Completed   0          37m
mongodb-1-stgkq                   1/1     Running     0          37m
nodejs-mongodb-example-1-2mjts    1/1     Running     0          90s
nodejs-mongodb-example-1-build    0/1     Completed   0          3m2s
nodejs-mongodb-example-1-deploy   0/1     Completed   0          99s

Comment 30 errata-xmlrpc 2019-06-04 10:40:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.