Bug 144747 - .rpmnew files created when updating packages with both i386 and x86_64 coexisting
.rpmnew files created when updating packages with both i386 and x86_64 coexis...
Status: CLOSED DUPLICATE of bug 128622
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 22:43 EST by D. Hugh Redelmeier
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-05 08:54:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Hugh Redelmeier 2005-01-10 22:43:25 EST
Description of problem:
My FC3 x86_64 system has a lot of .rpmnew files, all created during
installation of fedora-supplied updates.

These .rpmnew files were created by 'rpm -F' even though they are not
needed: in each case the old file and the new file are identical.

Version-Release number of selected component (if applicable):
RPM version 4.3.2

How reproducible:
This happened a bunch of times: for each of the following packages. 
Each is installed in an i386 form and an x86_64 form.  Each has been
updated since the release of FC3:
hal-0.4.2-1.FC3
kdebase-3.3.1-4.3.FC3
kdelibs-3.3.1-2.4.FC3
krb5-libs-1.3.6-2
mysql-3.23.58-14
pam-0.77-66.1
samba-common-3.0.10-1.fc3


Steps to Reproduce:
Take an FC3 system with old versions of any of these packages (both
the i386 version and the x86_64 version must be installed).
Do an rpm -Fv new.i386.rpm new.x86_64.rpm
  
Actual results:
mysql-3.23.58-14
mysql-3.23.58-14
warning: /etc/my.cnf created as /etc/my.cnf.rpmnew
[Notice also that the -v output does not describe the package in
enough detail for the reader to realize there is one for i386 and one
for x86_64]

Expected results:
No warning, no .rpmnew created.
Comment 1 Tomas Mraz 2005-08-05 08:54:28 EDT

*** This bug has been marked as a duplicate of 128622 ***

Note You need to log in before you can comment on or make changes to this bug.