Bug 144752 - Amarok fails to start after first start
Summary: Amarok fails to start after first start
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok   
(Show other bugs)
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-11 06:44 UTC by Rick L Vinyard Jr
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 08:53:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Amarok 1.1.1 spec (5.83 KB, text/plain)
2005-01-12 04:01 UTC, Rick L Vinyard Jr
no flags Details

Description Rick L Vinyard Jr 2005-01-11 06:44:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
The first time amarok is started, it runs fine. But, after starting
once it cannot find the communication sockets it expects.

Version-Release number of selected component (if applicable):
amarok-1.1.0-2

How reproducible:
Always

Steps to Reproduce:
1. Install amarok
2. Start amarok and close
3. Start again
    

Actual Results:  Amarok fails to start and provides user with an error
message. Debug logs show that it is failing to connect to KDE sockets.

Expected Results:  Amarok should start.

Additional info:

There is a more current release of amarok (1.1.1) available. Perhaps
this would be easier to target than trying to fix 1.1.0?

Comment 1 Michael Schwendt 2005-01-11 07:33:14 UTC
What do you see? Something like...?

$ amarok
[amaroK loader] connecting to
/home/misc/.kde/socket-faldor.intranet/amarok.loader_socket
[amaroK loader] exiting.

Are you sure that Amarok has quit and has not docked into the KDE panel?


Comment 2 Aurelien Bompard 2005-01-11 08:04:07 UTC
Amarok is composed of two programs : 
 - amarokapp: the "real" amarok
 - amarok: a simple loader, which reacts like Michael's commment. It's
used to make sure only one amarok is running, and to pass commands
like --next, --stop, etc

A possible problem could be that you do not use the dock, and as
clicking on the "close window" button defaults to minimizing Amarok to
dock, you cannot access it afterwards. Are you using KDE with kicker ?

I'll update Amarok when 1.2 is stable (currently beta3, it should
happen soon).

Comment 3 Aurelien Bompard 2005-01-11 08:08:00 UTC
Oh yes, and by the way, version 1.1.1 is in the QA queue at fedora.us :
https://bugzilla.fedora.us/show_bug.cgi?id=2183
I forgot a bit about this one, I'll probably publish it soon.

Comment 4 Rick L Vinyard Jr 2005-01-12 04:01:57 UTC
Created attachment 109655 [details]
Amarok 1.1.1 spec

Comment 5 Rick L Vinyard Jr 2005-01-12 04:02:51 UTC
Yes, the output is very similar to the output I was getting. Amarok
wasn't running, and wasn't docked. I am using KDE and kicker.

I went ahead and modified the amarok spec for 1.1.1 and built it on
x86_64 and all seems well now.

Comment 6 Thorsten Leemhuis 2005-03-23 18:42:40 UTC
Amarok 1.2.2 seems to be out in between -- Is this bug still valid or can it be
closed?

Comment 7 Rick L Vinyard Jr 2005-03-24 00:37:21 UTC
Bug is fixed with new version, so it should probably be closed.


Note You need to log in before you can comment on or make changes to this bug.