Bug 144755 - Typo or grammar error in messages
Typo or grammar error in messages
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 05:11 EST by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 16:14:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix typo/grammar errors in desktop-file-utils-0.9 (3.27 KB, patch)
2005-01-11 05:13 EST, Moritz Barsnick
no flags Details | Diff
patch to fix typo/grammar errors in desktop-file-utils-0.10 (3.27 KB, patch)
2005-01-11 05:14 EST, Moritz Barsnick
no flags Details | Diff

  None (edit)
Description Moritz Barsnick 2005-01-11 05:11:00 EST
Description of problem:
In many messages of desktop-file-utils there are grammar or typo 
errors in messages. The word "contain" is used where "contains" 
(singular) is appropriate.

Version-Release number of selected component (if applicable):
0.9-2

How reproducible:
always

Steps to Reproduce:
1. grep contain src/eggdesktopentries.c
  
Actual results:
e.g.:
_("desktop entry contain line '%s' which is not "

Expected results:
_("desktop entry contains line '%s' which is not "

Additional info:
I'm reporting this here since both authors named in the AUTHORS file 
have @redhat.com e-mail addresses.  ;-)  So I thought this might be 
as upstream as it gets.

Version 0.10 is available (you should know best ;->). Anyway, I'm 
attaching patches against 0.9 and against 0.10.
Comment 1 Moritz Barsnick 2005-01-11 05:13:19 EST
Created attachment 109596 [details]
patch to fix typo/grammar errors in desktop-file-utils-0.9
Comment 2 Moritz Barsnick 2005-01-11 05:14:04 EST
Created attachment 109597 [details]
patch to fix typo/grammar errors in desktop-file-utils-0.10
Comment 3 Moritz Barsnick 2005-01-11 05:16:25 EST
Adding authors to Cc:. Hope you don't mind...
Comment 4 Ray Strode [halfline] 2005-08-31 11:40:43 EDT
Hi Moritz,

Did this fall through the cracks, or did it get fixed upstream?
Comment 5 Moritz Barsnick 2005-08-31 12:36:23 EDT
I can find no newer version than the reported 0.10 upstream. There is no 
approriate commit in CVS either (there's been hardly any action in CVS at all). 
So I guess this report is still valid.

There is no category for desktop-file-utils in freedesktop.org's bugzilla 
(https://bugs.freedesktop.org/). As I originally explained, I even pretty much 
consider this "upstream". ;-)

This bug ticket apparently never got out of the status NEW, and the latest 
desktop-file-utils in Fedora devel (0.10-2) also still contains this bug, so it 
wasn't silently fixed either. It was either ignored or it fell through the 
cracks. *shrug*

Thanks for noting, Ray.
Comment 6 Ray Strode [halfline] 2005-08-31 16:14:43 EDT
Hi,

I've commited your patch upstream.  It should land in rawhide the next time
desktop-file-utils is released.

Note You need to log in before you can comment on or make changes to this bug.