Bug 14476 - gnome-terminal doesn't handle proportional fonts
Summary: gnome-terminal doesn't handle proportional fonts
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-22 21:41 UTC by Trond Eivind Glomsrxd
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-24 16:07:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trond Eivind Glomsrxd 2000-07-22 21:41:21 UTC
When selecting a proportional font (like Adobe Times) for gnome terminal,
_lots_ of extra white space shows up.

Comment 1 Havoc Pennington 2000-07-24 16:07:02 UTC
The only way proportional fonts make sense is to add padding to each character
to emulate a fixed width font; this is what xterm does. I'll send the bug
upstream, but even if it's fixed I'm not going to put the patch in Winston 
because it will almost certainly require significant code changes and
potentially introduce instability.

Comment 2 Havoc Pennington 2001-07-12 17:48:09 UTC
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=57442

Closing in RH bugzilla


Note You need to log in before you can comment on or make changes to this bug.