Bug 1447607 - Don't allow rebalance/fix-layout operation on sharding enabled volumes till dht+sharding bugs are fixed
Summary: Don't allow rebalance/fix-layout operation on sharding enabled volumes till d...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1447630
Blocks: glusterfs-3.11.0
TreeView+ depends on / blocked
 
Reported: 2017-05-03 10:06 UTC by Raghavendra Talur
Modified: 2017-05-30 18:51 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1447606
: 1447630 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:51:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Talur 2017-05-03 10:06:30 UTC
+++ This bug was initially created as a clone of Bug #1447606 +++

Description of problem:

Expanding a gluster volume that is sharded may cause file corruption
Sharded volumes are typically used for VM images, if such volumes are expanded or possibly contracted (i.e add/remove bricks and rebalance) there are reports of VM images getting corrupted.
If you are using sharded volumes, DO NOT rebalance them till this is fixed
Status of this bug can be tracked here, #1426508

Comment 1 Worker Ant 2017-05-05 08:26:46 UTC
REVIEW: https://review.gluster.org/17181 (glusterd: disallow rebalance & remove-brick on a sharded volume) posted (#2) for review on release-3.11 by Raghavendra Talur (rtalur@redhat.com)

Comment 2 Worker Ant 2017-05-09 11:35:14 UTC
COMMIT: https://review.gluster.org/17181 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit c72ac23fdc1d41c3a01d20bbad802e7dc7f21c2f
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Wed May 3 16:42:22 2017 +0530

    glusterd: disallow rebalance & remove-brick on a sharded volume
    
    Change-Id: Idfbdbc61ca18054fdbf7556f74e195a63cd8a554
    BUG: 1447607
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/17160
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    (cherry picked from commit 8375b3d70d5c6268c6770b42a18b2e1bc09e411e)
    Reviewed-on: https://review.gluster.org/17181
    Tested-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>

Comment 3 Shyamsundar 2017-05-30 18:51:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.