Bug 1447628 - [RGW]: "error in read_id for object name: default : (2) No such file or directory" message seen when rgw commands are run
Summary: [RGW]: "error in read_id for object name: default : (2) No such file or direc...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: rc
: 2.3
Assignee: Casey Bodley
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-03 11:07 UTC by Tejas
Modified: 2017-07-30 15:46 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-19 13:32:43 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC

Description Tejas 2017-05-03 11:07:37 UTC
Description of problem:
   This error message is seen when most of the radosgw-admin commands are run.

magna077 ~]# radosgw-admin bucket list --cluster slave1
2017-05-03 09:32:10.580572 7f01a73dd9c0  0 error in read_id for object name: default : (2) No such file or directory   <----------
[
    "lop",
    "bad",
    "new1",
    "bigbucket4",
    "bigbucket3"
]


Version-Release number of selected component (if applicable):
ceph version 10.2.7-13.el7cp (4955aa6a90abc27bc043729db19df24e1c840eac)

How reproducible:
Always


Additional info:

This seems to be resolved upstream:
http://tracker.ceph.com/issues/15776

If that is the case, we just need tp pull downstream.

Comment 2 Tejas 2017-05-03 11:10:57 UTC
I forgot to mention that this error message was seen on a multisite setup.
Also it does not affect the command ouput.

Thanks,
Tejas

Comment 9 Casey Bodley 2017-05-12 16:25:03 UTC
The tracker issue and upstream fix being referred to here was just to provide a 'more descriptive error message' for this - all it did was change what the error message says. That change is indeed present in the downstream build being tested here.

But the original reported issue is that the error message is shown in the first place. Removing that error message (by reporting it at a higher log level) would be an additional code change that has not been made upstream. I'll propose such a change.

Comment 14 Tejas 2017-05-15 11:24:39 UTC
Verified in ceph version:
ceph version 10.2.7-16.el7cp

>radosgw-admin bucket list --cluster master
[]

Comment 15 Razvan Musaloiu-E. 2017-05-23 14:25:57 UTC
(In reply to Casey Bodley from comment #9)
> The tracker issue and upstream fix being referred to here was just to
> provide a 'more descriptive error message' for this - all it did was change
> what the error message says. That change is indeed present in the downstream
> build being tested here.
> 
> But the original reported issue is that the error message is shown in the
> first place. Removing that error message (by reporting it at a higher log
> level) would be an additional code change that has not been made upstream.
> I'll propose such a change.

I think https://github.com/ceph/ceph/pull/9686 is fixing the issue on the
master. Maybe backporting that PR is all that needs to be done here.

Comment 18 errata-xmlrpc 2017-06-19 13:32:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.