Bug 144769 - Distorted sound with 2.6.10-1.737_FC3 and AC97
Distorted sound with 2.6.10-1.737_FC3 and AC97
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2005-01-11 08:51 EST by Tony Bourke
Modified: 2015-01-04 17:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 02:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Copy of the esd.conf file containing the change outlined in my post, for example purposes. (162 bytes, text/plain)
2005-03-20 19:35 EST, Brian Lusk
no flags Details

  None (edit)
Description Tony Bourke 2005-01-11 08:51:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When I loaded up on the new kernel-2.6.10-1.737_FC3, audio was
distorted, especially on the high-end.  Booting kernel-2.6.9-1.667
runs the audio perfectly.  

My board uses AC97 audio.  The distortion isn't severe, as in
guitar-amp distortion, but it's noticable especially on the high-end
and it makes listening to music unpleasent.  You probably wouldn't
notice it just playing system sounds.

It's not "jerky" mp3s, where the audio skips around, it's just distorted.



Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3, snd_via82xx

How reproducible:
Always

Steps to Reproduce:
1. Boot up with 2.6.10-1.737_FC3
2. Launch any audio app that plays music.  I use xmms.
3. Play an mp3, listen to the distorted high-end.
    

Actual Results:  Audio is distorted.  Not severely, but enough to tell
and enough to impair listening to mp3s.  

Expected Results:  Audio should have played fine.  It plays ok in
2.6.9-1.667

Additional info:
Comment 1 Sammy 2005-01-11 11:08:03 EST
I have reported this also on the devel branch but with snd_intel8x0 there 
is NO sound at all. Going back fixes the problem either like above or 
to 1.1063_FC4. The culprit is the sound updates in the -ac8 patch. 
Comment 2 Aaron Luchko 2005-01-11 12:13:42 EST
I can confirm that with 
Vendor: Intel
Model: Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
Module: snd_intel8x0 
and 2.6.10-1.737_FC3 I get no audio, again booting
kernel-2.6.9-1.681_FC3 fixes the problem.
Comment 3 T Williams 2005-01-12 02:28:23 EST
I also don't get sound on the main speakers after upgrading to
kernel-2.6.10-1.737_FC3.i686.  Headphones still work.
Downgrading to kernel-2.6.9-1.724_FC3.i686 makes the speakers work again.

My system: Compaq Presario X1000 series (X1404) laptop,
Intel AC'97 Audio Controller (82801DB/DBL/DBM, ICH4/ICH4-L/ICH4-M).
Relevant modules seem to be: snd_intel8x0m, snd_intel8x0, snd_ac97_codec.

Comment 4 Mike Cohler 2005-01-12 08:08:06 EST
I have also had a loss of sound on two of the three machines on which
I have booted to the latest kernel (2.6.10-1.737) since the 10th
January update.  Previously there have been no sound problems at all.

On one machine I have the following audio card:
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686
AC97 AudioController (rev 50)
        Subsystem: VIA Technologies, Inc. VT82C686 AC97 Audio Controller
In this machine it appears to detect the card OK, and I can play the
test sound in the KDE control centre sound section, but the music
players such as XMMS partly hang and definitely produce no sound at all.

Mike
Comment 5 Kent Engström 2005-01-14 07:16:32 EST
Also experienced loss of sound with kernel 737_FC3 on IBM R40 with

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/
ICH4-M) AC'97 Audio Controller (rev 03)

With the new 741_FC3 kernel, sound works again.
Comment 6 Mike Cohler 2005-01-15 09:36:38 EST
I have the loss of sound problem with both the 737 and 741 kernels
with my Dell Dimension 2400 - running FC3 all updates current and
sound controller details as:

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)

Comment 7 Mike Cohler 2005-01-15 11:24:21 EST
I have the loss of sound problem with both the 737 and 741 kernels
with my Dell Dimension 2400 - running FC3 all updates current and
sound controller details as:

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
Comment 8 Mike Cohler 2005-01-15 12:23:48 EST
After reading the many comments in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=144742 I tried
switching off headphone sense jack and line sense jack in Alsa Mixer
and I now have sound back again with the 741 kernel in FC3 - so I
presume there will be a fix released via updates at some point.
Comment 9 Owen Taylor 2005-01-18 13:40:45 EST
The distorted sound problem might be ESD doing software rate
conversion from 44k to 48k, something that happened years
ago with AC97 audio, though it was fixed more recently.

ESD does a really horrible job at that, and it sounds hideous.
Comment 10 Bo Bichel Nørbæk 2005-01-21 12:13:52 EST
I use the kernel (2.6.9-1.667) which is included in the 
distribution of FC3. All sounds are distorted at my system. 
 
Comment 11 Bo Bichel Nørbæk 2005-02-01 11:16:02 EST
Two days ago I tried to install FC3 freshly (instead of upgrading it 
from FC1). When booting FC3 for the first time and asked to 
configure the sound card, the test sound was clear and undistorted. 
 
However, in KDE all sounds were distorted. I think that other people 
have already reported the details of the sound problems in KDE. 
 
My sound card is a Soundblaster Live! 5.1, if that is of any 
interest. 
Comment 12 Pete Tranter 2005-03-05 15:20:25 EST
I'm using kernel 2.6.10-1.770_FC3 freshly installed. M/B MSI k7N2 Delta 
with AC97. Athlon 2500+ and 512MB memory. All updates are installed.

Sound Card detection finds the AC97 and plays the guitar sounds clearly.
The RealPlayer plugin in FireFox is clear.
Maelstrom and Tuxracer have garbled sound.
The CD player finds the CD and goes through the the tracks, but no sound. 
Comment 13 Brian Lusk 2005-03-20 19:25:29 EST
Here is a little more information that might help fix this bug.

I killed the ESD daemon and played with manually specifying various settings. 
While nothing seemed to help, when I ran:

esd -r 48000

in a terminal window, then tried various system sounds and Tux Racer, the sound
came out correctly on my system.  The default rate of 44100 apparently doesn't
work well with some AC97 audio setups.

Hopefully, this will help someone come up with a permanent solution.  And, if
anyone can tell me how to make this change permanent in some way, shape or form,
I'd appreciate it!

Sincerely,
Brian Lusk
Comment 14 Brian Lusk 2005-03-20 19:35:24 EST
Created attachment 112163 [details]
Copy of the esd.conf file containing the change outlined in my post, for example purposes.
Comment 15 Brian Lusk 2005-03-20 19:36:32 EST
Holy frijole, I think I have a fix!

Edit /etc/esd.conf

add " -r 48000" to the line that starts with "spawn_options="

Restart esd or re-enable sounds in the Start -> Preferences -> Sound dialog.

Voila!  Working sound!  At least, for me.

Sincerely,
Brian Lusk
Comment 16 Dave Jones 2005-07-15 13:42:34 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 17 Dave Jones 2005-12-07 02:56:44 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug with current FC3 updates, please
reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

If you are not the reporter, but can reproduce this problem against
FC4, please open a new bug.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.