Bug 1447830 - Export as PDF button also exports hidden sheets
Summary: Export as PDF button also exports hidden sheets
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Eike Rathke
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-04 01:36 UTC by Basil Eric Rabi
Modified: 2017-05-09 17:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-09 17:09:58 UTC
Type: Bug


Attachments (Terms of Use)
Reproducer document (9.21 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-05-04 14:49 UTC, Basil Eric Rabi
no flags Details

Description Basil Eric Rabi 2017-05-04 01:36:37 UTC
Description of problem:
Exporting as PDF using the button also exports hidden sheets.

Version-Release number:
5.2.6.2-6.fc25

Steps to Reproduce:
1. Create multi-sheet work book
2. Hide several sheets
3. Export as PDF using button

Actual results:
A pdf file is created including hidden sheets

Expected results:
A pdf file is created without the hidden sheets

Comment 1 Caolan McNamara 2017-05-04 09:33:52 UTC
Is "Export hidden pages" selected if you use file->export as pdf ?

Comment 2 Basil Eric Rabi 2017-05-04 09:58:42 UTC
I can't find the "Export hidden pages" option in the export pdf options. What tab is it located?
The following tabs are present in my version: "General", "Initial View", "User Interface", "Links", "Security", and "Digital Signatures".

Comment 3 Caolan McNamara 2017-05-04 11:38:39 UTC
oh wait, you're talking about calc and spreadsheet sheets, not impress hidden slides. Impress has the include/don't include hidden slides feature, disregard that question.

In calc if I create a new spreadsheet with content on two slides and then hide one by right clicking on its tab and "hide sheets" and then export to pdf with the dialog or with the one click icon I get output pdf that does not contain the hidden sheets. So I can't reproduce.

For you does it make a difference to use the dialog vs single click icon ? Can you provide a reproducer document.

Comment 4 Basil Eric Rabi 2017-05-04 14:49:52 UTC
Created attachment 1276368 [details]
Reproducer document

Using the dialogue and the single click yield to the same result.

Also, it seems that this issue cannot be reproduced when the workbook is created by Calc. I have a workbook that was created by MS Excel first.

Comment 5 Caolan McNamara 2017-05-05 13:31:12 UTC
caolanm->erack: any idea about this calc specific issue ?

Comment 6 Eike Rathke 2017-05-09 17:09:58 UTC
The document has Print Ranges defined on each sheet, for sheet S2 the range $A$1:$I$52, so this is actually expected behaviour. To suppress from printing and PDF generation unhide/show the sheet and under menu Format -> Print Ranges -> Edit... set Print Range to -none- and then hide the sheet again.


Note You need to log in before you can comment on or make changes to this bug.