Bug 1447831 - don't parse/format vram attribute for cirrus video
Summary: don't parse/format vram attribute for cirrus video
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux Advanced Virtualization
Classification: Red Hat
Component: libvirt
Version: 8.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jonathon Jongsma
QA Contact: Lili Zhu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-04 01:45 UTC by Fangge Jin
Modified: 2019-07-18 21:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-18 21:11:21 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Fangge Jin 2017-05-04 01:45:59 UTC
Description of problem:
   Set video type to cirrus, start vm, parameter "vgamem_mb" is not in qemu command line.

Version-Release number of selected component:
   libvirt-3.2.0-3.virtcov.el7.x86_64
   qemu-kvm-rhev-2.9.0-2.el7.x86_64

How reproducible:
   100%

Steps to Reproduce:
   1. Prepare a guest with the following xml:
   # virsh dumpxml rhel7-3
   ...
    <video>
      <model type='cirrus' vram='16384' heads='1' primary='yes'/>

   2. Start guest
   # virsh start rhel7-3

   3. Check qemu command line:
   # ps aux|grep cirrus
   ... -device cirrus-vga,id=video0,bus=pci.0,addr=0x2

Actual results:
   As step 3 

Expected results:
   vgamem_mb should be in qemu command line:
   ... -device cirrus-vga,id=video0,vgamem_mb=16,bus=pci.0,addr=0x2

Comment 2 Gerd Hoffmann 2017-10-06 11:58:18 UTC
> Expected results:
>    vgamem_mb should be in qemu command line:
>    ... -device cirrus-vga,id=video0,vgamem_mb=16,bus=pci.0,addr=0x2

No.  cirrus vga memory size isn't configurable.  Well, actually it is, but only for live migration backward compatibility reasons.  But in any case the amount of video memory usable by the guest is fixed at 4MB, period.

libvirt should not try to muck with vgamem_mb.

If anything libvirt should drop vram=... from xml for type=cirrus.

Comment 5 Jonathon Jongsma 2019-07-18 21:11:21 UTC
I proposed a patch to 'fix' this issue by essentially removing the parameter from the xml as suggested by Gerd above. But in the end, I decided that this wasn't really worth fixing since it's not really a bug.


Note You need to log in before you can comment on or make changes to this bug.