Bug 1447924 - F26 ppc64 installed on LPAR does not start automatically
Summary: F26 ppc64 installed on LPAR does not start automatically
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 26
Hardware: ppc64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker F26PPCBeta
TreeView+ depends on / blocked
 
Reported: 2017-05-04 09:02 UTC by Éric Fintzel
Modified: 2017-06-08 08:56 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-08 08:56:06 UTC


Attachments (Terms of Use)

Description Éric Fintzel 2017-05-04 09:02:20 UTC
Description of problem:
When verifying correction of bug https://bugzilla.redhat.com/show_bug.cgi?id=1435154 by installing on LPAR.
The installation was successful on both ppc64 and ppc64le LPARs, but when rebooting at the end of installation, restart is not automatic for ppc64.
For ppc64le, the system reboot, the SMS menu appears, after the timeout grub appears and Fedora starts automatically up to the login prompt.
For ppc64 the LPAR reboot but does not start automatically, the SMS menu appears, then it appears a second time, when the  system disk is manually selected grub appears with automatic start of Fedora. It seems the system disk to boot is not identified automatically.

Steps to Reproduce:
1. Install Fedora 26 ppc64 on a LPAR
2. Reboot or start the LPAR

Actual results:
Installed Fedora does not boot automatically.

Expected results:
System should start automatically as for ppc64le.

Additional info:
Tested with following images:
Fedora-Server-dvd-ppc64-26-20170424.n.0.iso
Fedora-Server-dvd-ppc64-26-20170426.n.0.iso
Fedora-Server-dvd-ppc64-26-20170502.n.0.iso
The behaviour is the same for any successive reboot of the ppc64 LPAR.
The behaviour is the same for a graphical or text install.

Fdisk on the installation disk:
[root@furax7 ~]# fdisk -l /dev/sda
Disk /dev/sda: 20 GiB, 21474836480 bytes, 41943040 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xbf8db4aa

Device     Boot   Start      End  Sectors Size Id Type
/dev/sda1  *       2048    10239     8192   4M 41 PPC PReP Boot
/dev/sda2         10240  2107391  2097152   1G 83 Linux
/dev/sda3       2107392 41943039 39835648  19G 8e Linux LVM
[root@furax7 ~]#

Comment 1 Éric Fintzel 2017-06-08 08:56:06 UTC
Unable to reproduce since a power outage in our lab and the restart of LPARs servers. Now ppc64 has the same behaviour than ppc64le.


Note You need to log in before you can comment on or make changes to this bug.