Bug 144794 - tg3 driver on BCM5703X won't load. Says tg3: Could not obtain valid ethernet address, aborting.
tg3 driver on BCM5703X won't load. Says tg3: Could not obtain valid ethernet ...
Status: CLOSED DUPLICATE of bug 208925
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Andy Gospodarek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 11:34 EST by Ingvar Hagelund
Modified: 2014-06-29 18:57 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 17:47:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci-nv.txt (3.89 KB, text/plain)
2005-01-13 03:13 EST, Ingvar Hagelund
no flags Details

  None (edit)
Description Ingvar Hagelund 2005-01-11 11:34:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
Installed the u4 kernel, and bootet. The tg3 driver seems unable to
use the bcm card. Works well with kernel-2.4.21-20.EL. 

Reverting to an older kernel (2.4.21-20.EL) works.

Version-Release number of selected component (if applicable):
kernel-2.4.21-27.0.1.EL

How reproducible:
Always

Steps to Reproduce:
1. Boot 2.4.21-20.EL
2. Watch
    

Actual Results:  tg3 driver unable to use the bcm controller

Expected Results:  tg3 driver loads and works

Additional info:

System is a HP Proliant DL-380 G3 with two on-board BCM adapters.
lspci reports "Broadcom Corporation NetXtreme BCM5703X Gigabit
Ethernet (rev 02)"

At boot, the driver twice (once for each controller, I guess) reports:

tg3.c:v3.10RH (September 14, 2004)
tg3: Could not obtain valid ethernet address, aborting.
eth0: Tigon3 [partno(TBD) rev 1002 PHY(5703)] (PCIX:100MHz:64-bit)
10/100/1000BaseT Ethernet 00:0b:cd:6c:d3:18
eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[1]
TSOcap[0]

I see HP recommends their version of the bcm5700 driver instead of the
tg3 driver on ES3. Which version would RedHat recommend?
Comment 1 John W. Linville 2005-01-11 14:08:40 EST
Ingvar, can you please attach the output of `lspci -nv`?  Thanks!
Comment 2 Ingvar Hagelund 2005-01-13 03:13:57 EST
Created attachment 109709 [details]
Output of lspci-nv.txt
Comment 3 Pete Caldes 2005-05-02 16:21:12 EDT
I have the same issue on one of my IBM Model x335 servers which uses the 
BCM5703 ethernet chipset. The weird thing is that it works on one of my other 
x335 machines with the same hardware.

The only difference is the firmware versions of the NIC's.
If I compile and use the bcm5700 driver, the machine that fails has firmware 
version 2.21a, while the one that works has version 2.25.

My problem is that there is no way to tell what the firmware version is on a 
running machine unless I use the bcm5700 driver. I have many machines but 
cannot risk upgrading the kernel without knowing for sure what the current 
firmware version is.
Comment 4 Pete Caldes 2005-05-02 16:24:34 EDT
Oops. Forgot to explicitly mention that both servers (old and new firmware) 
work fine with the bcm5700 driver (v7.3.5).
Comment 5 John W. Linville 2005-05-03 09:27:39 EDT
I have test kernels with a much later tg3 driver here: 
 
   http://people.redhat.com/linville/kernels/rhel3/ 
 
Please give those kernels a try and post the results here.  Thanks! 
Comment 6 Pete Caldes 2005-05-06 20:37:37 EDT
I had previously tried an updated kernel-2.4.21-27.0.2.EL.src.rpm from RHN 
with no luck.

I compiled your kernel-2.4.21-32.2.EL.jwltest.20.src.rpm test kernel and it 
too still fails the same way... :(

p.s.
Just curious on the Redhat Kernel naming/versioning scheme.
The 2.4.21 is due to the version number of the base kernel from kernel.org and 
EL stands for Enterprise Linux. But what do the other numbers mean or should I 
say what are they based on?
i.e.
kernel-2.4.21-27.0.2.EL
kernel-2.4.21-32.2.EL
Comment 7 Ernie Petrides 2005-05-06 21:25:28 EDT
Hello, Pete.  I can answer that one (being the RHEL3 kernel pool maintainter).

Following is an excerpt from internal mail regarding this (from well over a
year ago).  Just so you know, the U5 kernel (that is currently in beta) is
version 2.4.21-32.EL.  Ongoing development in the U6 pool is using -32.x.EL.

Cheers.  -ernie



[...]   We are trying to move toward a more flexible model whereby we
have multiple (parallel) code streams undergoing changes, some of which
may be released to customers.

Here's a table of possible names that we expect to use:

	-4.EL		initial release of RHEL 3
	-x.EL		an official RHEL 3 Update release (where x > 4)
	-x.0.z.EL	an official RHEL 3 Errata release based on -x.EL

	-x.y.EL		internal Engineering builds in an Update stream
	-x.y.z.EL	possible Interim builds offered to select partners
			    and customers with time-critical requirements
			    (branched from -x.y.EL where y > 0)

In all of these cases, x, y, and z are numbers with potentially more than
one digit.  There is also a convention of appending arbitrary text strings
(matching the regular expression [a-zA-Z0-9._]*) to any of the conventions
above to identify an internally built kernel that is not supported.  This
is used by developers providing special testing/debugging kernel packages
whose use outside of Red Hat is transient.
Comment 8 Dennixx 2006-11-22 08:50:16 EST
I have the same problem with the latest RHEL4 kernel (2.6.9-42.0.3.ELsmp) on a HP Proliant DL380 G3. This problem happens once out of two reboots. Boot once, it works, reboot, it doesn't work.  
Comment 9 Andy Gospodarek 2006-12-05 10:27:32 EST
For RHEL3 this looks to be the same as BZ 208925, which is committed to be fixed
in the next release.  Can you test with one of the kernels here:

http://people.redhat.com/agospoda/#rhel3

Comment 10 Andy Gospodarek 2006-12-05 10:28:41 EST
For RHEL3 this looks to be the same as BZ 208922, which is committed to be fixed
in the next release.  Can you test with one of the kernels here:

http://people.redhat.com/agospoda/#rhel4
Comment 11 Andy Gospodarek 2006-12-05 10:30:18 EST
Comment #10 is in reference to RHEL4.
Comment 12 Ernie Petrides 2006-12-05 17:47:12 EST
Forget the RHEL4 testing.  This is a RHEL3 bug, and the fix has already been
committed to the 2nd RHEL3 U9 interim build (kernel version 2.4.21-47.2.EL).

*** This bug has been marked as a duplicate of 208925 ***

Note You need to log in before you can comment on or make changes to this bug.