Bug 144802 - cannot connect to tightvnc server with vncviewer
cannot connect to tightvnc server with vncviewer
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 12:18 EST by Cameron Meadors
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-01 07:20:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcpdump of vnc connection (700 bytes, application/octet-stream)
2005-01-11 16:48 EST, Cameron Meadors
no flags Details
tcpdump of vnc traffic (both directions) (700 bytes, application/octet-stream)
2005-05-27 14:13 EDT, Cameron Meadors
no flags Details

  None (edit)
Description Cameron Meadors 2005-01-11 12:18:31 EST
Description of problem:

Cannot connect to a tightvnc server using vncviewer.  Java client
connects just fine.


Version-Release number of selected component (if applicable):

vnc-4.0-8

How reproducible:

Try to connect to a tightvnc server with vncviewer.
  
Actual results:

I get the following output and no vnc window:

VNC viewer for X version 4.0 - built Oct  6 2004 08:06:12
Copyright (C) 2002-2004 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.

Tue Jan 11 11:39:30 2005
 CConn:       connected to host colobus.boston.ximian.com port 5901
 CConnection: Server supports RFB protocol version 3.130
 CConnection: Using RFB protocol version 3.8

Tue Jan 11 11:39:43 2005
 main:        CleanupSignalHandler called


Expected results:

A vnc window pops up.

Additional info:

I install tightvnc client and it connects just fine.  This seems like
a incompatibility in the RFB version, 3.008 (realvnc) vs. 3.130
(tightvnc).
Comment 1 Tim Waugh 2005-01-11 12:43:35 EST
No, 3.130 means that 3.xxx (xxx <= 130) is supported.  The client selects 3.8
and the server is obliged to comply.  Note that 3.130 is not an official
protocol version in any case:

  http://www.realvnc.com/docs/rfbproto.pdf

When you say "Java client" you of course mean you are using the client supplied
to the web browser by the TightVNC server, so it is not surprise that it works.

Please attach the captured TCP traffic from running this command before your
connection (and control-C it afterwards):

  tcpdump -U -s 0 -w rfb.pcap port 5901
Comment 2 Cameron Meadors 2005-01-11 16:47:02 EST
Here is the tcpdump you asked for.  FYI, the client is Fedora Core 3 running
realvnc, obviously, and the server is NLD which uses tightvnc.  I am also going
through a VPN, but that shouldn't make any difference because it works with the
tightvnc client.
Comment 3 Cameron Meadors 2005-01-11 16:48:18 EST
Created attachment 109641 [details]
tcpdump of vnc connection
Comment 4 Tim Waugh 2005-01-12 06:23:25 EST
For some reason this seems to only contain the outbound traffic.  Please try:

tcpdump -U -s 0 -w rfb.pcap src port 5901 or dst port 5901
Comment 5 Cameron Meadors 2005-05-27 14:13:48 EDT
Created attachment 114924 [details]
tcpdump of vnc traffic (both directions)
Comment 6 Cameron Meadors 2005-05-27 14:28:12 EDT
Just tried vnc-4_1_1-1.i386.rpm from realvnc.com.  Got the same result.
Comment 7 Tim Waugh 2005-06-01 07:20:10 EDT
This still only has the outbound traffic.  However, what outbound traffic there
is shows that the client is acting correctly, and that the server is not.

Note You need to log in before you can comment on or make changes to this bug.