Bug 1448179 - Hammer auth-source didn't list all sources
Summary: Hammer auth-source didn't list all sources
Keywords:
Status: CLOSED DUPLICATE of bug 1336236
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.2.8
Hardware: All
OS: All
unspecified
high vote
Target Milestone: Unspecified
Assignee: Dominik Hlavac Duran
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-04 17:30 UTC by Waldirio M Pinheiro
Modified: 2019-08-12 14:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-02 13:53:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 18584 None None None 2017-07-10 11:23:01 UTC
Foreman Issue Tracker 19651 None None None 2017-05-24 12:02:44 UTC
Red Hat Bugzilla 1336236 None None None Never

Internal Links: 1336236

Description Waldirio M Pinheiro 2017-05-04 17:30:54 UTC
Description of problem:
Customer would like to see all sources instead only the ldap source via hammer command

Version-Release number of selected component (if applicable):
6.2.9

How reproducible:
100%

Steps to Reproduce:
1. via cli type *hammer auth-source ldap list*
2. Via cli and as postgre user type *psql -d foreman -c "select id,name,type from auth_sources;"*
3.

Actual results:
Are different

Expected results:
Should be the same or at least just add one option in hammer like below to show all sources
*hammer auth-source "all" list*

Additional info:

Comment 1 Waldirio M Pinheiro 2017-05-04 17:31:37 UTC
Below one example


// Query from hammer
---
# hammer -p redhat auth-source ldap list
---|------|--------|------|---------------
ID | NAME | LDAPS? | PORT | SERVER TYPE   
---|------|--------|------|---------------
3  | w2k8 |        | 389  | AuthSourceLdap
---|------|--------|------|---------------
#
---

// Query from db
---
$ psql -d foreman -c "select id,name,type from auth_sources;"
 id |   name   |        type        
----+----------+--------------------
  1 | Internal | AuthSourceInternal
  2 | Hidden   | AuthSourceHidden
  3 | w2k8     | AuthSourceLdap
(3 rows)
$
---

Comment 2 Marek Hulan 2017-05-05 06:15:34 UTC
Hello Waldirio. Could you please explain, why customer would want to see these?

The hammer command reflects what's displayed in UI. AuthSourceHidden is obviously hidden from users and is used for internal purpose (it's used by internal anonymous admin user). AuthSourceInternal is auth source for users which password is stored in internal DB, there's nothing to configure for it, therefore it's also hidden. The only legitimate auth source type that should be displayed except for LDAP auth source is external auth source, which is only created when user configures it using the installer. It's normally used only if users want to use kerberos/IPA authentication. This is already tracked as BZ 1336236.

Comment 3 Waldirio M Pinheiro 2017-05-05 22:15:06 UTC
Hi Marek, good afternoon

I saw one ExternalSource and I asked customer what procedure / steps was used to create that one once he would like to see via hammer command.

When customer send me the reply I'll update the BZ

Thank you!!

Comment 10 pm-sat@redhat.com 2017-07-10 10:04:35 UTC
Upstream bug assigned to dhlavacd@redhat.com

Comment 11 pm-sat@redhat.com 2017-07-10 10:04:39 UTC
Upstream bug assigned to dhlavacd@redhat.com

Comment 13 Marek Hulan 2018-07-02 13:53:36 UTC
this is a duplicate of 1336236, closing

on Satellite 6.4.0 snap9

# hammer auth-source list
---|-------------|--------------------
ID | NAME        | TYPE OF AUTH SOURCE
---|-------------|--------------------
1  | Internal    | AuthSourceInternal 
3  | win2012R2AD | AuthSourceLdap     
5  | External    | AuthSourceExternal 
---|-------------|--------------------

*** This bug has been marked as a duplicate of bug 1336236 ***


Note You need to log in before you can comment on or make changes to this bug.