Bug 144831 - gnome-panel-screenshot not stripping *special* chars when using window title as screenshot filename
Summary: gnome-panel-screenshot not stripping *special* chars when using window title ...
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-11 20:22 UTC by James Laska
Modified: 2013-09-02 06:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-12 18:18:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-panel-screenshot failure (124.21 KB, image/png)
2005-01-11 20:22 UTC, James Laska
no flags Details

Description James Laska 2005-01-11 20:22:14 UTC
RPM gnome-panel-2.8.1-6.i386

When using firefox, and attempting to take a window screenshot (<alt>PrntScrn),
I attempted to save the screenshot to my desktop.  However, I am presented with
an error dialog indicating that it did not have permissions to write the file. 
However, the real problem is it attempted to save the file while not escaping
'/' characters from the filename.  Hence, it tried to save the file
"/home/jlaska/Desktop/Screenshot-Index of /~komornik/tasche/fedora - Mozilla
Firefox.png".  Of course this fails due to the '/' in the filename.  I think
simply escaping the '/' as '\/' would fix this.

Comment 1 James Laska 2005-01-11 20:22:15 UTC
Created attachment 109637 [details]
gnome-panel-screenshot failure

Comment 2 Mark McLoughlin 2005-01-12 12:40:27 UTC
jrb: is this fixed upstream?

Comment 3 Jonathan Blandford 2005-01-12 18:18:26 UTC
Yuppers.


Note You need to log in before you can comment on or make changes to this bug.