Bug 144840 - Update to 0.4b38
Update to 0.4b38
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dump (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
http://dump.sourceforge.net
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 16:34 EST by Kenneth Porter
Modified: 2013-07-02 19:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-12 04:39:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth Porter 2005-01-11 16:34:16 EST
From the upstream announcement:

From: Stelian Pop <stelian@popies.net>
To: dump-announce@lists.sourceforge.net
Subject: [Dump-announce] Dump/restore 0.4b38 released.
Date: Fri, 7 Jan 2005 15:09:53 +0100

Hi everybody.

A new version of of dump/restore, the Linux ext2/ext3 filesystem
backup utilities, has been released today.

This release features several small bug fixes and a number of
performance enhancements, see the full ChangeLog below for full
details.  
 
The next version of dump/restore will feature EA/ACL support, and
there is already a beta patch implementing this. If you use EA/ACLs,
please do test this patch and report back (get the patch from dump's
homepage).

The dump/restore's homepage is located at:
	http://dump.sourceforge.net

Happy new year !

Stelian.

Changes between versions 0.4b37 and 0.4b38 (released January 7, 2005)
=====================================================================

1.	Fix a couple of troff syntax bugs in the man pages.
	Thanks to Eric Raymond <esr@thyrsus.com> for the patch.

2.	Made restore use either libncurses or libtermcap, depending
	on which one is available at configure time.

3.	Fixed restore negative size display bug when comparing a
	dump containing files over 2GB. Thanks to Steve Bonds
	<sbonds@users.sourceforge.net> for the bug report.

4.	Do not save directory entries to non-dumped inodes 
	(excluded from dump). This will eliminate the 'missing
	file' warnings when doing 'restore -C'.

5.	Fix dump crash when backuping a huge (2TB) filesystem,
	due to a bogus calculation on the inode map size.
	Thanks to Kevin B. Haines <K.B.Haines@rl.ac.uk> for 
	submitting the bug and testing the fix.

6.	Fix a problem in restore where the final \0 in the symbolic
	link names could have been lost, generating corrupt filenames.
	Thanks to Kyle Wilson <kyle.wilson@amd.com> for reporting the
	bug.

7.	Implemented a hash list for the directory names in restore.
	The linear list used before caused problems in interactive
	restores when dealing with directories having thousands of
	entries. Thanks to Brian Ristuccia <bristuccia@starentnetworks.com>
	for reporting the bug.

8.	Improved restore -C, this time including the directory
	attributes into the comparision.

9.	Made restore understand tapes containing EA/ACLs (which will
	be dumped by the next version of dump). In this version 
	extended attributes on the tape are ignored, for full EA/ACL
	support wait for the next version or try the experimental EA
	patch.
-- 
Stelian Pop <stelian@popies.net>    


-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
_______________________________________________
Dump-announce mailing list
Dump-announce@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/dump-announce
Comment 1 Kenneth Porter 2005-01-11 16:40:15 EST
FYI, I'm currently running the upstream RPM with the EA patch on FC2.
It builds fine and I'll cc any reports of problems here.
Comment 2 Kenneth Porter 2005-01-11 18:33:39 EST
Hold off on this one. I just ran into problems with restore -C
(compare) trying to actually restore files, not a good thing.
Comment 3 Jindrich Novy 2005-01-12 04:39:28 EST
Kenneth, thanks for the update announce. I built dump-0.4b38 including
the experimental patch to devel. I'm going to build updates for FC2,
FC3 likely without the patch.

Note You need to log in before you can comment on or make changes to this bug.