Bug 144844 - up2date freezes more often than not
up2date freezes more often than not
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Depends On:
  Show dependency treegraph
Reported: 2005-01-11 17:10 EST by Pavel Simerda
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-29 10:09:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Stdout/stderr from up2date on a fresh 'everything' system. (7.29 KB, text/plain)
2005-01-14 17:59 EST, Penelope Fudd
no flags Details

  None (edit)
Description Pavel Simerda 2005-01-11 17:10:32 EST
Description of problem:
I installed fedora core 3 and  I tried to update the system. After I
had chosen "all packages" it showed me a progress dialog and get
frozen (did not redraw and did not respond). I tried it several times
width the same result.

Than I tried to update only a small number or single packages with
success (sometimes on first try, sometimes on second) which made my
system unstable due to version incompatibilities.

Finally I succeeded to update the most necessary packages but up2date
is still unstable.

BTW I had not seen an up2date update there.

The crash comes at any time up2date is running but mostly it is when
there's a progress dialog.

I'm afraid have no more information to help you.

Version-Release number of selected component (if applicable):

How reproducible:
Often, not always

Steps to Reproduce:
1. Lauch up2date and enter root password
2. Select several packages (the more you select the better to reproduce)
3. Click Forward and look at the progress dialog
Actual results:
Up2date freezes

Expected results:
It should download the list of packages, then (after your choice)
download the packages and then (after clicking forward) install them.
Comment 1 Pavel Simerda 2005-01-12 09:11:33 EST
I succeeded to finish the updates. It was a bit better but still 
experiencing hangups. 
Comment 2 Penelope Fudd 2005-01-14 17:59:04 EST
Created attachment 109800 [details]
Stdout/stderr from up2date on a fresh 'everything' system.
Comment 3 Penelope Fudd 2005-01-14 18:01:23 EST
I just installed FC3 'everything' on a new system, and then ran
up2date immediately.  It's frozen downloading rpm headers, and the
progress dialog says "Fetching rpm header: cyrus-imapd-utils-2.2.10-3.fc3"
Comment 4 Walker Aumann 2005-02-10 12:10:39 EST
Same thing.  Stuck at the "Testing package set / solving RPM
inter-dependencies" dialog every single time (about 10 attempts now).  
Comment 5 Walker Aumann 2005-02-10 12:17:21 EST
...but up2date --nox -u seems to work.  
Comment 6 Matthew Miller 2006-07-10 17:11:45 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 7 John Thacker 2006-10-29 10:09:27 EST
Closing per lack of response to previous comment.  If this still occurs on FC3
or FC4 and is a security issue, please assign to Fedora Legacy and the
appropriate version.  The bug could also be filed against RHEL if it is relevant

up2date has been replaced by pirut and pup in FC5 and FC6, the still fully
supported versions of Fedora Core, so this bug will not be fixed unless it is a
security issue.

Note You need to log in before you can comment on or make changes to this bug.