Bug 144848 - Kernel 2.6.10-1.737_FC3 breaks snd_intel8x0 driver
Kernel 2.6.10-1.737_FC3 breaks snd_intel8x0 driver
Status: CLOSED DUPLICATE of bug 144742
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 17:24 EST by Jeremy Brown
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 21:16:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Brown 2005-01-11 17:24:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I apologize in advance if this bug has already been filed.  I have
seen a few bugs here regarding the snd_intel8x0 driver but did not
believe they were directly related to this bug (which has just popped
up in the latest kernel release, for me at least).

When I fire up an application like XMMS and attempt to play audio, the
application acts like it's shuttling data to the driver (e.g. shows
visualization data) but no sound can be heard.

I checked volume control and unmuted everything.  I tried to play
audio from multiple applications and using both oss and alsa with no
success.  I'm able to reboot into the kernel I was using previously
(kernel-2.6.9-1.724_FC3), and sound works fine.

My machine is an IBM Thinkpad T41.  Here is my lspci output:

00:00.0 Host bridge: Intel Corp. 82855PM Processor to I/O Controller
(rev 03)
00:01.0 PCI bridge: Intel Corp. 82855PM Processor to AGP Controller
(rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB2
EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corp. 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corp. 82801DBM (ICH4-M) LPC Interface Bridge
(rev 01)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4-M) IDE Controller
(rev 01)
00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf
[Radeon Mobility 9000 M9] (rev 02)
02:00.0 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus
Controller (rev 01)
02:00.1 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus
Controller (rev 01)
02:01.0 Ethernet controller: Intel Corp. 82540EP Gigabit Ethernet
Controller (Mobile) (rev 03)
02:02.0 Network controller: Intel Corp. PRO/Wireless LAN 2100 3B Mini
PCI Adapter (rev 04)

And here is my lsmod output:

Module                  Size  Used by
udf                    74437  1
parport_pc             26501  1
lp                     12077  0
parport                36617  2 parport_pc,lp
autofs4                22981  0
smbfs                  60473  2
rfcomm                 36445  0
l2cap                  26053  5 rfcomm
bluetooth              48069  4 rfcomm,l2cap
sunrpc                154149  1
arc4                    1857  1
ieee80211_crypt_wep     4673  1
pcmcia                 20805  4
ipt_REJECT              6593  1
ipt_state               1857  2
ip_conntrack           40309  1 ipt_state
iptable_filter          3521  1
ip_tables              16321  3 ipt_REJECT,ipt_state,iptable_filter
dm_mod                 55509  0
video                  15813  0
ibm_acpi               15997  0
button                  6609  0
battery                 9285  0
ac                      4805  0
md5                     4033  1
ipv6                  230273  12
joydev                  9217  0
yenta_socket           19137  0
pcmcia_core            50817  2 pcmcia,yenta_socket
uhci_hcd               31321  0
ehci_hcd               34761  0
i2c_i801                8141  0
i2c_core               20801  1 i2c_i801
snd_intel8x0m          18181  2
snd_intel8x0           32865  2
snd_ac97_codec         67105  2 snd_intel8x0m,snd_intel8x0
snd_pcm_oss            47861  0
snd_mixer_oss          17089  3 snd_pcm_oss
snd_pcm                92233  4
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              28357  1 snd_pcm
snd                    52261  11
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9889  3 snd
snd_page_alloc          9541  3 snd_intel8x0m,snd_intel8x0,snd_pcm
ipw2100                75897  0
ieee80211              19397  1 ipw2100
ieee80211_crypt         6469  2 ieee80211_crypt_wep,ieee80211
e1000                  81557  0
floppy                 57329  0
ext3                  116041  1
jbd                    68185  1 ext3


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot into FC3 using kernel-2.6.10-1.737_FC3
2. Attempt to play audio via XMMS or some other audio app, using OSS
or ALSA drivers
    

Actual Results:  No sound could be heard.

Expected Results:  I should have heard sound.

Additional info:
Comment 1 Dave Jones 2005-01-13 21:16:29 EST

*** This bug has been marked as a duplicate of 144742 ***

Note You need to log in before you can comment on or make changes to this bug.